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MOBILE CHECKLIST B. CONFIGURE REPLICATION ———

IMPORTANT: Before beginning the Mobile configuration process, complete all
items listed in Mobile Checklist A: Preparation.

In these steps, the Enterprise Server (file hosting), Replication Server, and Web
Server are distinguished. If you are working on an ideal setup, where all three
servers are actually the same machine, then apply all instructions given for any of
the three servers to your unified server.

PART 1: CONFIGURING SDE AND THE BACKDROP DATABASE

STEP 1 PREPARE THE ENTERPRISE SDE GEODATABASE

For an SDE geodatabase to act as the final authority on all data involved
in a Mobile implementation, the SDE geodatabase must first be
compatible with the version of ArcFM currently installed. The tables
and fields within the SDE geodatabase should be assigned the necessary
ArcFM model names before any other Mobile databases are created.
This step assumes you have already completed the enterprise SDE
geodatabase preparation tasks included in Checklist A.

U On the Enterprise Client, run Start > Programs >
ArcGIS > ArcCatalog.

O In the ArcCatalog tree on the left, expand Database
Connections.

U Double-click Add Spatial Database Connection
and enter all connection information.

) uncheck Save the transactional version name
with the connection file.

Building Your Mobile
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The simplest arrangement is for
SDE to own the Sync version
and the InitialExtract version.
However, any user may own the
Initial Extract version as long as
the Replication Server is given the
correct user name and password
to access it.

STEP 2: CREATE THE INITIALEXTRACT VERSION

The sync version (normally
DEFAULT) must be the parent of
the InitialExtract version. The
version you right-click over before

choosing New will be the parent of
the new version.

Building Your Mobile
© Telvent. All rights reserved.

Spatial Database Connection Properties @EJ

Server. |vmrmobwleed

Service: |51 51

Database: |sde
(IF supported by your DBMS]
Acount

' Database authentication

Usemame: |sde

Password: |
V¥ Save uzemame and password

" Dperating system authentication

Corinection details

The following transactional version will be used:

|sde.DEFAULT Change.
I Save the tranzactional version name with the connection file.
Test Connection Cancel

Unchecking the option to save the transaction means that every time you
connect to the enterprise SDE geodatabase, you will be prompted to
choose a version. Choosing the correct version each time is essential to a
successful Mobile implementation. At key moments, connecting to the
wrong version could create problems significant enough to require
redoing much work. For example, when copying data into the new
Backdrop database, it is essential to connect to the InitialExtract version,
not the Sync version.

) Verify that the version is the Sync version (typically
sde.DEFAULT).

Q cClick [ OK].

This connection will be referred to as the entSDEgdb connection
throughout these checklists.

The InitialExtract version marks a key moment in the life of the
enterprise SDE geodatabase. All edits made to the Sync version before
the InitialExtract version is created will be included in the Backdrop
geodatabase. All edits made to the Sync version after the InitialExtract
version is created will not be included in the Backdrop geodatabase.
These later edits will be added to the Backdrop geodatabase through
replication after the Backdrop has been moved to the Field Unit.

U Right-click the entSDEgdb connection and choose
Versions.

O Inthe Version Manager window, right-click over
DEFAULT and choose New.
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£ Version Manager (sde on vm-mobileed) E]@

[ Mame __ [owner  [Access |LastModiicd |
DEFALI New... = Public 9/8/2008 10:...
Rename
Delete
Refresh
Properties...
't| p A version name that begins with an o
underscore will appear toward the U For Name enter _InitialExtract
top of any forward-sorted version
\I/lggicl)fnyr?:n?: chmozﬁ Lonzgarrstc?é’ U For Description enter Do not delete

remember to include that
underscore in every property field
you encounter that requires the
Initial Extract Version name.

(] Set Permission to Private.

Mame
o . |_Initia|E:<tract

After Mobile is running
successfully, you can delete the Description
InitialExtract version. D0 MOT DELETE
However, if this version is deleted
before the first server-side
replication run, you will have to
redo much of your configuration Bk
work, including creating a new & Private
Backdrop geodatabase. )

" Public

" Protected

Cahicel
O click [OK].

U Close the Version Manager window.

The InitialExtract version should be used only at the proper times during
replication configuration and initialization. To double-check that
InitialExtract will not be the default connection version you will revisit
the enterprise SDE geodatabase connection properties.

U Right-click the entSDEgdb connection and choose
Connection Properties.

U Verify that Save the transactional version name
with the connection file is NOT checked.

Building Your Mobile
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Conneclion details
The following transactional version will be used:
[sde DEFALLT Change... |

I [ Save the ransactional version name with the connection file I

Test Connection Cancel
O click [ OK].

STEP 3: CREATE THE BACKDROP GEODATABASE

You will create the Backdrop on the Enterprise Server, from which it
will be copied during the Field Unit’s first client-side replication run.

Optional: If implementing Redliner or Inspector,
and intending for field users to have the option of
saving redlines (graphics and ink) in an ArcFM
Annotation Feature Class, this class must be in a
separate dataset of its own, and must be included
in the Backdrop geodatabase. If there are multiple
ArcFM Annotation Feature Classes, they can all be
in the same dataset.

Look for the Connect to O click the Connect to Folder button and create a
Folder button on the Standard . .
toolbar. connection to the Enterprise Server base path. In

these steps, it is assumed that the Enterprise Server
base path will be accessible from a mapped drive Z:.

Connect to Folder @ @

Choose the folder to which you want to connect:

ra

=l [Z} Desktop

+ "_'| My Documents

= iy My Computer
+|- =g Local Disk (C:)
#% DVD/CD-RW Drive (D:)
BB heContaner on Vi mobieee’ 23]
#-|3) Shared Documents
+-{) train's Documents

+- &4 My Network Places

+/-{) Course Data

OK l [ Cancel

O click [OK].

U Expand Z: and TheBaseFolder.

Building Your Mobile
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t| p Do not open the Connection
Properties in order to check
whether you are connected to
Initial Extract. Because we are
keeping Save the
transactional version name
with the connection file
unchecked, the Connection
Properties will always revert to
DEFAULT upon opening.

t| p Most Servers and Field Units will
not have ArcGIS Desktop software
installed. Therefore, any
operations requiring ArcCatalog
will be done by running
ArcCatalog on the Enterprise
Client and then opening a
connection within ArcCatalog to

the Server or Field Unit base path.

Building Your Mobile
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O Right-click InitialExtract and choose New >
Personal Geodatabase or File Geodatabase.

L Name the new geodatabase Backdrop

3 ArcCatalog - Arcinfo - Z:\TheBaseFolder\InitialExtract

File Edit View Go Tools Window Help
& | Gy ¥ o EE A @O N
Location ‘Z.".TheBaseFD\der'.lania\Exlmcl j

Stylesheet:

|| Cortents I Preview | Metadata | Model Names |
[ Catalog ~

Name | Type

2 [
= g 7\ i |Backdrop Personal Geodatabase

= TheBaseFolder
+-3 InitiaExtract
=I-(£ Database Connections
%3 Add OLE DB Connectior
@ Add Spatial Database €
-3 entSDEgdb
#-[_F Database Servers -
< *

Personal Geodatabase selected

O Right-click the entSDEgdb connection and choose
Disconnect.

U Right-click the entSDEgdb connection and choose
Connect.

L When prompted to specify a transactional version,
choose sde._InitialExtract.

Be very careful to choose the InitialExtract version! InitialExtract marks
a moment in time shortly before the creation of the Backdrop
geodatabase. After the Backdrop is in place on the Field Unit, any edits
made to the sync version after the InitialExtract version was created can
then be applied to the Backdrop database, bringing it up to date again.
However, if the Backdrop is created from some other version, important
edits might be missed in the first update, and will never reach the field
users.

O click [OK].

L Copy the desired datasets and feature classes from the
entSDEgdb connection into Backdrop using either
copy and paste or a schema and extract template.

Telvent recommends copy and paste.

U Right-click Backdrop and choose Create/Update
ArcFM Solution System Tables.

U Right-click Backdrop and choose Upgrade ArcFM
Solution Database.
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Next you will copy critical ArcFM properties (model names, shapping
settings, etc.) from the enterprise SDE geodatabase into the

Backdrop.mdb geodatabase.

U Right-click the entSDEgdb connection and choose

ArcFM XML Export.

U Connect to the Sync version if prompted.

O When the ArcFM XML Export window opens, check

all options.

L) Choose a convenient location for the file.

B3 ArcFM XML Export

: Iﬁ Export.

ArcFM Properties
ArcFM Relationship Class Info

><r1 This toal allows pou ta expart the selection ta an XML file.
Fleaze zelect the type of infarmation to export and click

£rcFi Model Name Information | [ FTogress

X

[ &cFM Snapping Information 3

4= >
Export

File to contain the exported data:

|C: WhrcFh data from enterprise SDE. wml

[~ Apply Style Sheet

Browsze

Export | Cancel |

O click [ Export].

O If prompted to export another file, choose [ No ].

ArcFM XML Export

O Right-click Backdrop.mdb and choose ArcFM XML

Import.
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B ArcFM XML Import g]

This tool will allow you ko populate the selected
gendatabase with information contained in an #kL
D:> file. Please choose an option below and click [mport.
Options Frogress
v Ovensrite

™ Keep Existing

" Prompt

Impaort
#ML file to import:

|EI:\Arc:FM data from enterprise SDE.=<ml

[ &pply Style Sheet

Iport | Cloze |

U Choose Overwrite.

L Browse to the file you just exported.

O click [ 1mport].
You may choose to see a list of information that was not imported. Since
the Backdrop database contains fewer tables than the enterprise SDE

geodatabase, many of the enterprise properties will not apply to the
Backdrop.mdb.

O If prompted to import again, choose [ No ].

ArcFM XML Import

Next you will add the Set ServerOIDs command to the ArcCatalog
interface and run it. If you used the schema and extract template method
to populate the Backdrop database, you do not need to run Set
ServerOIDs.

U From the Tools menu, choose Customize.

U Inthe Customize dialog, display the Commands
tab.

U Inthe Categories column on the left, choose
ArcFM Solution.
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Customize

Toolbars Commands lgptions]

PX

Show commands containing: |

ArcG15 8x Conversion Tools
ArcGIS 8x Data Management Tools

Categories: Commands:
30 View A |&]about AroFr Solution
ArcCatalo

? ArcFM Data Source Wizand
' ArcFM Favorites
8 41cFM Geodatabase Extraction

ArcGIS Servers ,‘.fr ArcFM Orphaned Versions Clear
ArcGlS Service = .
40T oolhos aj.&rcFM Properties M anager
Cadastral ArcFh OIDs
Caze Todls ¥ | ™ ArcFM Snanoing Manager b
4 > £
Savein |Momnal gut - Kevboard... | Add fram file... | Cloze |

U From the Commands column on the right, click and
drag ArcFM Set ServerOIDs onto any toolbar.

FolderMnitialExtract\Backdrop.mdb

QS O3 w2

ckdrop.mdb j

ArcFM Set ServerOIDs

Cantents I Preview | Metadata | Madel Names |

U Close the Customize dialog.
U In the ArcCatalog tree, select Backdrop.mdb.

L Click the new ArcFM Set Server OIDs button.

Set ServerOIDs may take from

_ U When the Successfully Set ServerOIDs message
30 minutes to several hours.

appears, click [ OK1].

ArckEM Set ServerQIDs

3

\14) Successfully Sek ServerOlIDs,

ArcFM relies on model name assignments to determine what roles each
database, table, and field will play in the GIS. The MM FIELD EDIT
database model name indicates that a database will act as the backdrop.

U Right-click the Backdrop database and choose
ArcFM Properties Manager.

Building Your Mobile
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O Display the Model Names tab.

tlp e A POt L Assign the MM FIELD EDIT model name to the
Manager is disabled until
Create/Update ArcFM Solution Backdrop database. If any other model names are
System Tables and Upgrade assigned to this database, unassign them.

ArcFM Solution Database have
been run on the database.

ArcFM Properties Manager EJ

Underground Faciities Model Names l

todel Mames
Model Mame Domain: |D0main Independent D atabaze Model Nej
Model names available: Model names selected:
MM FIELD EDIT MM FIELD EDIT
»
.
< ¥

QK | Cancel Apply

Q Click [ OK ].

PART 2: CONFIGURING THE REPLICATION SERVER

STEP 1: SET SERVER PROPERTIES

0 g;heliﬁ‘;;';'\: Sgr‘:]‘?sitsat?:fgr O onthe Replication Server, from the Start menu
Compmand appears twice in the choose Programs > ArcFM Solution > ArcFM
Start menu, you can launch the Geodatabase Replication > ArcFM Geodatabase
application_fro_m either Ii_stin_g. It Rep“cation Administrator.
appears twice if the Replication
Web and the Replication Server i .
software have both been installed D In the AI’CFM Geodatabase Repllcatlon
on the same server (this is the ideal Administrator, from the File menu choose Open
arrangement). If desired, you may Configuration File
remove either command from the )
Start menu.
ReplicationConsol i U Browse to C:\Program Files\Miner and Miner\
eplicationConsole.exe.config 1S ArcEM Solution\Bin\
an XML file listing all the i ) i
Replication Server properties ReplicationConsole.exe.config.
which can be set and providing
gng?JIdeegaél;:/te\l{algéi)sligrti?:(r:nc;nsoIe O In the tree on the left side of the ArcFM Geodatabase
.exe_cor',ﬁg is an XML file listing Repligatio_n Administrator, right-(_:lick over
the same Replication Server ReplicationConsole.exe.config and choose New >
properties, but with examples Server.

provided for all values.

Building Your Mobile
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To register anew ESRI license
file (.ecp), run Start > Programs
> ArcGIS > Software
Authorization. Choose “I have
received an authorization file from
ESRI and am now ready to finish
the registration process” and click
Next. Choose “I received the
authorization file by email and
have saved it to disk." Click the
Browse button and locate the .ecp
file. Click Next. Click Finish. The
next time you open the ArcFM
Geodatabase Replication
Administrator, it will recognize the
license(s) granted in the chosen
.ecp file

Building Your Mobile
© Telvent. All rights reserved.

& ArcFM Geodatabase Replication Administrator
File Action Help

De  Ed
= ‘fi-'] ArcFM Geodatabaze Replication | B General
- e liert ~"Program Files\Miner and Miner\A
Server
Web Service

Mew Configuration File  Chrl+h
Save Configuration File  Chrl+5

U on the right side of the window, under General, click in
the Server Base Directory field.

r
&9 ArcFM Geodatabase Replication Administrator™
Elle Action Help
DezEd
= “"a-'J ArcFM Geodatabase Replication | B General
=< C:\Pragram Files\Miner and b | 1 Base Directory
- J Server B License Settngs

U Click the Browse (three dot) button to browse to the
Enterprise Server base directory, e.g.
C:\TheContainer\TheBaseFolder. Do not browse
to any directory within it.

Browse For Folder, E| g|

155 Install -
25 Licenses
I25) mssql
IC5) Program Files
[E Pythonzs
125 Scripts
= & TheContainer
SR TheEaseFolder
125 InitialExkract

1£5) WINDOWS
F = rar i

Make Mew Folder ] [ OF ] [ Cancel

( Set the ESRI and Telvent licenses to match your
available licenses.

a ArcEM Geodatabase Replication Administrator™
File A&ction Help

e @ a
- a] ArcFi Geodatabaze Replication | B General
--[1 C:\Program FilestMiner and M| Server Base Directary
- J Server E License Settngs
1 General Category ESRI Licenze Geodatabase Update Extension
Tehvent Miner & biner Licenze Engine Viewer
= G E A G E A NS ArcFM Engine Editor Extension j

C:ATheContainer\TheBaszeFolder
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To confirm the necessary
Telvent licenses are available,
run Start > Programs > ArcFM
Solution > License Manager >
Desktop Administrator.

STEP 2: SET REPLICA PROPERTIES

Categories are used to organize
multiple replicas, much like folders
are used to organize multiple files.
If you only have one replica, the
Category Name does not matter. If
desired, you may rename the
General Category by selecting it in
the tree on the left, then changing
the name on the far right.

Building Your Mobile
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L) From the File menu, choose Save All.

U I1fany Configuration Errors appear in the lower
part of the dialog, resolve them before proceeding any
further. If there are license errors, you may not be
able to save your settings until the licenses are
registered in the ArcGIS Software Authorization or
ArcFM Desktop Administrator tools.

Configuration Ermors

Mame Froperty Description Fath

Server GlobalServerRe..  EaiLicense {esilicenseProductCodedrcl..  C:\Program Files...
Ready

Now that you have confirmed access to the necessary licenses, you will
declare the locations of critical folders and databases and give a name to
this replica — the entire system of enterprise base path, Backdrop
geodatabase and enterprise SDE geodatabase used to provide updates for
specific tables or geographic areas to field users. These steps show how
to create and configure only one replica, but you may repeat them with
different replica names to create replicas for data that update at different
intervals (e.g. landbase vs. facility) or for distinct geographic areas
(service territories, counties, etc.), allowing field users to subscribe only
to the replicas they need.

0 In the tree on the left, select General Category.

] From the Action menu, choose New > Personal
Geodatabase Replica or File Geodatabase
Replica depending on which type of backdrop you
created.

ﬂ, ArcEM Geodatabase Replication Administrator

Directary Replica

=  Rename File Geodatabase Replica
=% Remove Personal Geodatabase Replica e e
‘Validate Ctri+Shift+Yy Process Framewark Replica Server eneral Lategory

L On the right side of the window, for the Replica
Name enter the replica name (e.g.
TheReplicaName).
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You can temporarily set Enabled
to False in order to prevent
replication from running.

Building Your Mobile
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89 ArcFM Geodatabase Re plication Administrator™

File Action Help

e Eda
=] :';J ArcFM Geodatabasze Replication | © General -
=] C:AProgram Files\Miner and b [ e Reuns TheReplicaMame
=] J Server [rescription
-] General Category Enabled True
EL Personal Geodats Personal Geodatabaze File Mame
Initial Extraction Directory

The Replica Name matches the Field Unit’s files with the appropriate
information on the Web Server and Replication Server. If the Field Unit,
Web Server, and Replication Server have any difference in Replica
Name, replication will not work. Therefore, give the replica a simple
descriptive name and make sure to use the same Replica Name when
configuring the Web Server and Field Unit.

Q) If desired, type a description into the Description
field.

O Verify that Enabled is set to True.

U For Personal (or File) Geodatabase File Name
click the Browse (three dot) button.

a ArcEM Geodatabase Replication Administrator™

Eile Action Help
O 3
= :';-J ArcFM Geodatabase Replication | B General

=[] C:\Program FilestMiner and b Replica Marme

- J Server

TheReplicaMame j
Description
—1-[_] General Categary Enabled

True
Eh IS ETENEY AN Fersonal Geodatabase File Name ] @

Imitial Estraction Directony
= AreSDE Settings

L Browse to the Backdrop database (e.g. in
C:\TheContainer\TheBaseFolder\InitialExtract).

O Click [ Open 1.

8 ArcEM Geodatabase Replication Administrator®

File Action Help
Ne g
= ";-] ArcFM Geodatabase Replication | @ General

=[] C:\Program FilegiMiner and b Repliza Mame
= J Server

TheReplicalame :1

Description
—1-[_] General Category Enabled True
Eh QR SEREGERI ' omal Geodatabase File Narne Backdrop.mdb J

Initial E straction Directory
= Arc5DE Settings
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U For Initial Extraction Directory, click the
Browse (three dot) button.

U Browse to the InitialExtract folder (e.g.

C:\TheContainer \TheBaseFolder\
InitialExtract).

Be sure to browse only to the InitialExtract directory, not to any specific
file, or this value will cause an error when you later try to save.

+ () Instal ~
I Licenses
+ () mssqgl
+ [ Program Files
+ [ Python2s
) Scripts
= @2 TheContainer
= |23 TheBaseFolder
R InitialExtract
£ ) WINDOWS
F [P e b

[ake Mew Folder ] l OF ] [ Cancel

O click [OK].

ﬂ ArcEM Geodatabase Replication Administrator™

File Action Help

= = ]

=] E—j ArcFM Geodatabaze Replication | © General -

—I-[1 C:AProgram FileshMiner and b Feplica Mame TheReplicaMame
- J Semver Descriptian
—-(_1] General Category Enabled True
TheReplicaMame | Personal Geodatabaze File Mame Backdrop.mdb
ion Directary C:ATheContainersTheB azeFol J
B ArcSDE Settings

When set to True, Compress

BEGIEERES U (S D 6, O If Backdrop is a file geodatabase, set Compress
However, this process may take Fal Th . C ing f PGDB
some time, so set Compress to to False. ere Is no Compress setting for a .
False while testing, then change it

to True when testing is complete. L For Server enter the ArcSDE Server name

(e.g. vm-mobileed).

O For Instance, Database, User Name, and
Password enter the same values you used in the
ArcCatalog Spatial Database Connection Properties. A
Database value is only necessary if the enterprise SDE
geodatabase is a SQL Server database.

Building Your Mobile
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If Keep Initial Version were
set to False, the Initial Extract
version would be deleted
immediately after the first
server-side replication run.
Normally, it is safer to keep the
Initial Extract version through the
first few replication runs just in
case reinitializing replication
becomes necessary.

Building Your Mobile
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Spatial Database Cor~~~tion Properties

Server |vm-m0bileed

on Administrator™

Service: |51 51

|sde /

S —

D atabase:

E General =
Feplica Mame TheReplicaMame
Diescription
Enabled True

Perzonal Geodatabaze File Name Backdrop.mdb

Iritial Extraction Directory C:ATheContainer\TheB aseF older’
= Arc5DE Settings
Server
Instance

|dzer M ame

-

O For Initial Extract Version specify the geodatabase
version from which the tables in the Backdrop
geodatabase were copied or extracted (e.g.

SDE. InitialExtract).

U For Sync Version specify the parent of the
InitialExtract version (e.g. SDE.DEFAULT).

O For Keep Initial Version choose True.

(]

Scroll down to Email Settings.

O For Email SMTP Server enter an email server
accessible from the Replication Server (formatted as in
sundance.miner .com).

L) For Email Address enter the email address of the
administrator for this Mobile implementation.

L Change any other settings as needed.
] From the File menu, choose Save All.

U I1fany Configuration Errors appear at the bottom
of the window, resolve them.

L] Once all errors are resolved, save the settings and
close the ArcFM Geodatabase Replication
Administrator.
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a ArcFM Geodatabase Replication Administrator®™

File Action Help
D= Ed
= :] ArcFM Geodatabasze Replication | E General =
=1 C:\Program Files\Miner and k| Replica Mame TheR eplicaName
= J Server Drescription
—-[L] General Categary Enabled True
TheReplicaName | Personal Geodatabaze File Name  Backdrop.mdb
Iritial E straction Directon C:\TheContainer\TheB aseFolder'
E ArcSDE Settings
Server wm-mobileed
Instance 5151
Database sde o
Uzer Mame zde
Pazsword adaded
Initial E xtract Yersion sde__InitialExtract
Sync Yersion SDE.DEFAULT
K.eep Initial Extract Wersion True
Cleanup Interval [dawz] 30
write #ML File True j
< 2| Fmail SMTP S arvar
Configuration Errors
Mame Property D escription Path
Ready

STEP 3: RUN ARCFM GEODATABASE REPLICATION SERVER

Q) still on the Replication Server, from the Start menu

If an error appears the first time choose Programs > ArcFM Solution > ArcFM
yourun ArcFM Geodatabase Geodatabase Replication > ArcFM Geodatabase
Replication Server, try . .

running it again. Replication Server.

This calls ReplicationConsole.exe, which runs server-side replication.

& ArcE Replication Status g|§|g|

TheR ephcalame
Bootstrap
Statuz changed at: 3/19/2010 3:00 Pk

Update Howl

If any errors appear in the ArcFM Replication Status box, note and
resolve them before proceeding. You can also check the Event Viewer
for more details on any errors.

STEP 4: TEST REPLICATION

Next you will edit the Sync version to test whether server-side
replication will successfully identify the edits and extract them for use in
Field Unit updates.

Building Your Mobile
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U On the Enterprise Client, start ArcMap.

O Inthe ArcFMm Login screen, browse to the
entSDEgdb spatial database connection.

U When prompted, choose the Sync version. If this is
not permitted, choose a child version of the Sync
version, then remember to reconcile and post the child
version to the Sync version before you run server-side
replication again.

U Apply a Stored Display.

U Inthe Table of Contents, Source tab verify that
the current version is correct. If necessary, change the
version on the Source tab by right-clicking the
connection and choosing Change Version, then
choosing the correct version from the list that appears.

= Layers s
= g sde, DEFALLT {wm-mobileed)
- 2§ arcfm. ARCFM. GasDataset
+ [7] Meter Setting
+ [Z] CP Anode
+ [ Distribution Main b
< >

Dizplay  Saource |Se|ectinn] Featurm] Cls I

Be absolutely certain you are not editing the InitialExtract version!

) From the Editor toolbar, Editor menu, choose
Start Editing.

Editor = " |

¥ Start Editing ‘

The ArcFM methad of sketching a O Sketch a new feature on the map. Zoom in if

point feature is to click the feature

in the Table of Contents, necessary.

Features tab; then enter any

required attributes in the ArcFM U Using one of the Identify tools, click on the new
Attribute Editor, Targets tab; feature to view its ObjectID.

then click on the map to place the

feature.

U Note the Feature Class and ObjectlD here:
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When you next run server-side replication, you will need this ObjectID
to determine whether the new feature was recognized as an edit.

] From the Editor menu choose Save Edits.

Editor * k| v Task [Create ArcFM Featur

B Stop Editing
By Save Edits

U From the Editor menu choose Stop Editing.
U Close ArcMap.

U If prompted to save changes to Untitled, choose
[ No].

L On the Replication Server, from the Start menu
choose Programs > ArcFM Solution > ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Server.

QO Inthe Enterprise Server base directory, browse to
the new Replica Name folder (e.g. C:\
TheContainer\TheBaseFolder\TheReplicaName)
and open the new Extract_<date time> folder
inside.

U Inthe Extract_<date time> folder, open the
XML file and confirm that your new feature is listed.

ti p [ 2 CovthecontainensTheBase Folder\TheReplizaametExtract_2010-0319-15-1.., @@‘
The XML file in the Extract e B cecmanenme v 4 [ ] [ 2l
folder lists any edits recognized by Hlo Edt Uow Favories Tods Help
the replication software as having 7z Favartes | (@ C:{TheContainer|TheBase. . - I - Pager Safety -
been ma_de aﬂe( the' previous il versionet 0" 7 =
server-side replication run. The o
XML file will not include edits - <editiog>
captured during previous <entrycount> L</entrycount>
server Slde replicatlon runs Aﬁ:er - <georow table="ARCFM.ARCFM.CPANODE" nid="6214" svroid="0"
= . op="new"s

its creation, the XML file is not e ey

inati field name=" " type="null’ /
accessed by any replication ZE e CPBYSTEMORIEGTIO ypectrul o
process e} you may vieW |t W|th0Ut <figld name="CREATIONUSER" typa="string">train</ficld>

field name="DATEGREATED" tvne="date"=3/19/2010</fizld

interfering in future replication.
All other files in the Extract folders
must not be opened, or you will

have to build and distribute a new Q) If the XML file does not list your newly created feature,
Backdrop geodatabase and restart then replication did not succeed. Check the Event
replication.

Viewer for error information, resolve any errors, and
run ArcFM Geodatabase Replication Server
again.
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L Once replication recognizes your new feature, test
each of the following edit types. You can test them all
in one server-side replication run, but make sure that
all five types of edits do appear in the resulting XML
file. For example, you may find that attribute updates
are recognized while feature deletions are not, in which
case you will need to resolve this error before
proceeding. Remember to save edits, stop editing, and
close ArcMap before running the ArcFM Geodatabase
Replication Server command.

Edit Feature | ObjectID Details
Class

Insert a feature

Delete a feature

Update an Changed attribute
attribute

from value

to value
Relate a feature to Object Class
an object

Object's OID
Unrelate a feature Object Class

and an object

Object's OID

PART 3: CONFIGURING THE WEB SERVER

IMPORTANT: These Web Server configuration instructions assume that
the Web and Replication Servers are the same machine. If your Web and
Replication Servers are different machines, see the ArcFM Solution help
for instructions on additional necessary steps, including creating and
configuring a domain user.

STEP 1 COMPLETE THE I1S INSTALLATION

) On the Web Server, open the Control Panel.
U Open Add or Remove Programs.

U From the left frame, choose Add/Remove Windows
Components.
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® Add or Remove Progran

\E‘jj Currently installed programs: [ show updates Sort by

Change or ’ -
Remove a ArcFM Engine Runtime 9.3.1
Programs F aport infe
-—
J
Add Mew J ArcFM Geodatabase Replication Server 9.3.1 Size  S54.06ME

?J ArcFM Geodatabase Replication Web 9.3.1 Size  39.50MB

ﬂ ArcGIS ArcSDE Far Microsoft SOL Server Size  148.00MEB

addiRemove [} Arcals Engine Runtime Size  552.00ME
‘Windows

Companents ﬁﬂ Microsoft JMET Framework 2,0 Service Pack 2 Size  156.00ME

ﬁl Microsoft \MET Framework 3.0 Service Pack 2 Size  178.00ME
ﬁj Microsoft \MET Framewark 3.5 SP1 Size  28.70MEB
D_‘, Microsoft Office 2003 Web Components Size  Z2.69MB ¥

Q) Verify that Application Server is checked, then
select it and click [ Details ].

Windows Components Wizard

Windows Components
*Y'ou can add o remove components of Windows,

To add or remove a companent, click the checkbox. A shaded box means that only
part of the component will be installed. Tao see what's included in a companent, click
Details.

LComponents:
Accessories and Ltilities 49MB A~

[ [8A Certificate Services 1.8 ME
[ 3 E-mail Services 1.1 ME
[T B 4F ax Servinas 7AMR ¥

Description: Includes ASP.MET, Internet Information Services [I15), and the
Application Server Conzole.

Total disk space required: 3.0MB -
Details...
Space available on disk: 5720.0 MB

< Back “ Mext » ][ Cancel ]

O Verify that ASP.NET is checked.

QO Verify that 11S is checked, then select it and click
[ Details ].

Application Server, (X

To add or remave a compaonent, click the check box. & shaded box means that only part
of the companent will be installed. To see what's included in a companent, click Details.

Subcomponents of Application Server,

'ﬁ] Application Server Console 0.0mMB
B ASPNET 0.0MB
(B Enable network COM+ access 00ME
O @ Enable network DTC access 0.0MB

[ 5 Message Queuing

Desciption: 115 Includes Web, FTP, SMTP, and MNTP support, along with support
for FrontPage Server Extensions and Active Server Pages [45P)

Tatal disk space required: 3.0MB -Delalls
Space available on disk: E720.0 MB _
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O Verify that Background Intelligent Transfer
Service (BITS) Server Extensions is checked,
then select it and click [ Details ].

O Verify that BOTH boxes are checked.

Background Intelligent Transfer Service (BITS) Server Extensions E|

To add or remove a component, click the check box. A shaded box means that only part
of the component will be installed. To see what's included in a component, click Details.

Subcomponents of Background Inteligent Transfer Service [BITS] Server Extensions:
@ BITS management 0.1 MB

7 BITS server extersion 1SAPI 0.1 MB

Description:  Installs the BITS shap-in so that users can configure and manage BITS
b using Microzoft Management Congole.

Total disk space required: J0ME
Space available on disk: 5720.0 MB

oK ] [ Cancel

Always check both BITS choices, not just one! ArcFM Replication
requires both BITS extensions.

U click [ OK ] to all dialogs until you return to the
Windows Component Wizard.

Windows Components Wizand

wWindows Components
‘You can add or remove components of Windows,

To add or remove a component, click the checkbox, A shaded box means that only
part of the component will be installed. To see what's included in a component, click
D etails.

Components:

Accessories and Utilities
Applicatior 1
[ [B Certificate Services
O E-mail Services

71 i34 Fax Servires

Description:  Includes ASPMET, Internet Information Services [[15], and the
Application Server Conzole.

Total disk space required: 3.0MB
Space available on disk: B720.0 ME

< Back ][ Mext > ][ Cancel

O Click [ Next] to run Configure Components.

U When the wizard is done, click [ Finish ]
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Because ArcFM GDB Replication Web is closely tied to 1S, after
changing these 1IS settings you may need to reinstall ArcFM GDB
Replication Web for it to function properly.

O Uninstall ArcFM GDB Replication Web. Be sure
you do not uninstall ArcFM GDB Replication Server.

U Run the ArcFMGDBReplicationWeb.msi installer
available from Telvent.

U Close the Add or Remove Programs window.

U Close the Control Panel.

STEP 2 CONFIGURE THE 1S APPLICATION PooL

L still on the Web Server, right-click My Computer
and choose Manage.

U Inthe Computer Management window, expand
Services and Applications > Internet
Information Services (11S) Manager.

g File Action Wew Window Help - E‘J
B @

5 Q Local Users and Groups A || nMame
4 @ Performance Logs and Alerts mSystem Tools
=) Device Manager Storage
- @ r;::wnvahle Storage @Services and Applications
B4 Disk Defragmenter
E Disk Management
= @ Services and Applications
= 8 Telephory
% Services
WMI Control
£ @ 0L Server Configuration Manager
B Indexing Service
= PJ Internet Information Services (115) Manager
+-__) Application Pools
+-_) Web Sites
#-_ web Service Extensions w| € S

U Right-click Application Pools and choose New >
Application Pool.
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An Application Pool isa
grouping of services and programs
which can be managed as a unit
(for assigning permissions, etc.).
The Application Pool ID you
specify will be visible in the 11S
Inetpub folder.

The ArcFM GDB Replication
Service is installed by the Telvent
ArcFM Replication Web software to
receive update requests when Field
Units run client-side replication.

The application should already
exist and have the name of
“Default Application.” However,
if the application has not yet been
created, a [ Create ] button will
be visible next to the Application
Name field. After the [ Create ]
button is clicked, it will be
replaced by the [ Remove ]
button.

Building Your Mobile
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O In the Add New Application Pool dialog, set the
Application pool ID (e.g.
TheApplicationPoolID).

Add Hew Application Pool @

Application pool ID: ThedpplicationPoalD

Application pool sektings
(%) Use defaulk settings for new application pool

() Use existing application poal as template

Application pool name:

K ] [ Cancel ] [ Help

) Choose Use default settings for new application
pool.

Q cClick [ OK].
O Inthe Computer Management window, under
Internet Information Services (11S) Manager

expand Web Sites > Default Web Site.

U Right-click ArcFMGDBReplicationService and
select Properties.

= Computer Management g@@
=) Fle  Action  View Window Help &=
& X B 2

£ Shared Folders | Hame Path

4 Local Users and Groups “Jtin

& Performance Logs and Alerts 2 Documentation

Device Manager
ehService.as. ..

Remavatle Storage Cpen

Disk Defragmenter Fermissions
yeb.loganet. ..

Disk Management Browse
b loganet. .

®
{4 Services and Applications
Hew »

® E Telephany
Services All Tasks 3
WM Contral View »
# {4 SQL Server Configuration Manager m

# I Indexing Service
= © Internet Information Services (I15) Mana ~ Delete

= g storage Explore

Hew Window from Here

= _) Application Pols Refresh
+-g DefaultAppPool Export List...
b+ TheapplicationPoolln
=) webStes Froperties

=@ Defaul Web Site
GERY A rcFMGDER D
& _J aspret_dient
) vweh Service Extensions

Help

U Choose the Virtual Directory tab.

Q) If thereis a [ Create ] button to the right of
Application Name, click this button.

O From the Application pool drop-down choose the

application pool you created (e.g.
TheApplicationPoolID).
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Arc FMGDBRe plicationService Properties E]E]

HTTP Headers Custom Errors BITS Server Extension ASPLHET
Wirtual Directory Documents Directory Security
The cantent for this resource should come Fram:
() & directory located on this computer

1S permissions vary at every

(& share located on another computer

customer site. Allow for time to © & redrection to a URL
tESt and adJUSt these SEttIngs untll Local path: CHiInetpublwiwroot| ArcFMGDEREplica
they are compatible with ArcFM [ seript source sccess [ Log wieks
Replication, and ensure that an i i
- ! Write
aUthOFIZGd member Of the Customer |:|D|rectorv brovsing
IT staff will be available to make Application sattings
these perm|ssion changes Wh||e Application name: Default Application
you are on site. Errors Stating Starting point: «Default Weh Site >\ ArcF... —
"Access Denied,"” "Can't Read" or Execute permissions: | Scripts only v (Cotarson..]
"Can't Write" are typically the Appiication pool: !
result of incorrect I1S permissions.
OF, ] [ Cancel ] I Apply I [ Help ]
O click [OK].

STEP 3: CONFIGURE THE VIRTUAL DIRECTORY

The Virtual Directory is simply an alias for the enterprise base path. The
Field Unit will access database updates from an address that includes the
Virtual Directory rather than the entire enterprise base path.

O Inthe Computer Management window, under
Internet Information Services (11S) Manager >
Web Sites, right-click Default Web Site.

L Choose New > Virtual Directory.

The Virtual Directory Creation Wizard will appear.

O In the welcome screen, click [ Next ].

U For the Virtual Directory Alias, enter a name for
the Virtual Directory (e.g. TheVirtualDirectory).
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Virtual Directory Creation Wizand El

Virtual Directory Alias @
Specify a short name, or alias, for this virtual directory. ;‘x:'

Type the alias you want to use Lo gain access to this Web vitual directory. Use the
zame naming conventions that pou would for naming a directony.

Alias:
ThetitualDirectary

< Back " Nest > ]l Cancel

Q Click [ Next].

U For the Path, browse to the enterprise base path
(e.g. C:\TheContainer\TheBaseFolder).

Yirtual Directory Creation Wizard

wWeb Site Content Directory
‘where is the content you want ta publish on the ‘web site? S

A [

G

Enter the path to the directory that contains the content for thiz Web site.

Path

|
Browse For, Folder @@

Wirtual Directory Creation Wizard

IJ) Licenses ~
125 mssaql
|53 Program Files
25 Pythonzs
|2 Scripts
1= (&3 TheContainer
(=N ] THeFaseFolder
[ InitialExtract
I Logs
[T TheReplicaMame

7= WITRRCAS

Make Mew Folder ] [ K ] [ Cancel

_ _ . O click [OK].
The Virtual Directory is just a

pointer to the base directory. The
Virtual Directory name acts as an O Click [ Next].
alias, easier to enter than the
precise location of the enterprise

base directory. U Check the Read, Write, and Browse permissions.
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Yirtual Directory Creation Wizand @

Vitual Directory Access Permissions @
Set the access permissions for this virtual directory. ‘?_*

Allow the following permiszions:

Bead

[] Run seripts [such as ASP)

[[] Execute [such as |SAP! applications o CGI)
it

To complete the wizard. click Next .

< Back " Mext » ]I Cancel

O Click [ Next].

O cClick [ Finish].

You now have a Virtual Directory listed under Web Sites. Because the
Virtual Directory is an alias for the enterprise base path, when you
expand the Virtual Directory you will see that everything contained in
the enterprise base directory is listed under the Virtual Directory.

L Expand TheVirtualDirectory to view its contents.

= f"] Internet Information Services (113 Manager
—-__ Application Pools
+-ghs DefaultAppPacl
+-gis ThedpplicationPoollD
= __| ‘Web Sites
= Default web Site
+ -Jj ArcFMGDEReplicationer vice
+_| aspnet_client
ThevirtualDirectory
+-__| InitialExtrack
#- ) Logs
+-__| TheReplicaMame
| ‘Web Service Extensions

STEP 4: ADD MIME T7YPES TO I1S

O Inthe Computer Management window, right-click
Internet Information Services (11S) Manager
and select Properties.
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Internet Information Services (11S) Manager Properties @@

Internet Information Services

Allows you o edit the IS metabase configuration file while 15 is
running.

UTF-& Logging
allows 15 to write log entries using UTF-8 encoding instead of local
code page.

[JEncode Web logs in UTF-5

MIME types
N TI5 serves only files with extensions
registered in ths MIME bypes list, To WIME Types. .
configure addtional Fils extensions,
click MIME Types.

U Inthe Internet Information Services (11S)
Manager Properties, click [ MIME Types ].

O Inthe MIME Types window, click [ New ].
O For Extensions enter .delta

O For MIME type enter
application/octet-stream

Extension: .delta

MIME type: applicationfoctet-stream

[ Ok ] [ Cancel

O cClick [OK].
O Inthe MIME Types window, click [ New ].
U For Extensions enter .xip

U For MIME type enter
application/octet-stream

QO cClick [ OK] to all dialogs.
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MIME Types X

Registered MIME types file extensions):

sy videofx-ms-wmy A F M
S wideo/x-ms-wm

sz applicationx-ms-wmz

.Wps applicationfvnd. ms-works
i application/x-mswrite
Lwarl s-worldfx-vrml =

iz se-warld -l
swsdl bextfxml

SV videox-ms-wyx
R application/direct:
xaf s-worldfx-vrml
b image c-xhitrap
e ket {plain

ip spplicationyoctet-stream

MIME bype details
Extension: ip

MIME type: application/actet-stream

[ 0K ] [ Cancel

U Right-click TheVirtualDirectory and choose
Properties.

(] Choose the HTTP Headers tab.
O Click [ MIME Types ].

Q) If the .delta and .xip types are not listed here, add
them.

QO cClick [ OK] to all dialogs.

U Close the Computer Management window.

STEP 5 SET WEB SERVER PROPERTIES IN THE ARCFM
GEODATABASE REPLICATION ADMINISTRATOR
U still on the Web Server, from the Start menu choose
Programs > ArcFM Solution > ArcFM

Geodatabase Replication > ArcFM Geodatabase
Replication Administrator.

U Inthe ArcFM Geodatabase Replication
Administrator, from the File menu choose
Open Configuration File.

0O Browse to C:\Inetpub\wwwroot\
ArcFMGDBReplicationService\Web.config.

QO click [ Open].

Q) If the Web.config file includes any sample replicas,
such as NortheastElectric or
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The Replica Name must be
identical on the Replication Server,
Web Server, and Field Unit for
replication to succeed.

Building Your Mobile
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NortheastLandbase, ri
Remove.

ght-click each one and choose

Tracking Web Server use is optional, but for this class you will keep

tracking turned on.

L (Optional) To log each time a field unit retrieves an
update, select the Web Service node and set Log
Client Activity to True.

ﬂ ArcFM Geodatabase Replication Administrator™ g@@
File Action Help

D a

=B } ArcFM Geodatabase Replication El General

=1 C:A\netpubbwasroothrcFMGDERe
-1 {1 Web Sevice
(1 General

Log Client Activity =

Log Chent Activity
Thizs walue specifies whether or nat client connections and downloads
are logged.

Next you will specify implementation details for your replica.

U Right-click the General category and choose New
> Personal Geodatabase Replica Web Service or

File Geodatabase Replica Web Service depending

on which type of backdrop you created.

U For Replica Name, enter the same Replica Name
used in the ReplicationConsole.exe.config file
configured earlier (e.g. TheReplicaName).

a_ Arcki Geodatabase Replication Administrator™
File Action Help

e  3a
= ij ArcFM Geodatabase Replication E General i‘
=-] CulnetpubheswrootsaricFMGDBRe | Replica Name TheReplicaMame
-0 Wweb Service Perzonal Geodatabaze File Mame J
- (] Gereral Plasa Miractom =

The Replica Name must be entered into the server
ReplicationConsole.exe.config, Web.config and the client
ReplicationConsole.exe.config with exactly the same spelling. If the
Replica Name differs in any of these three locations, replication will fail.

U For Personal (or File) Geodatabase File Name,
browse to the Backdrop geodatabase in the Enterprise
Server base path (e.g. C:\ TheContainer\
TheBaseFolder\InitialExtract\Backdrop.mdb).

QO click [ Open].
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A Base UNC value is only
necessary if you use UncCopy
instead of BITS.

All slash (virgule) characters in
the Base URL must be forward
slashes, not back slashes.

tip

STEP 6. TEST THE WEB SERVER CONFIGURATION

Building Your Mobile
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U For Base Directory, browse to the Enterprise Server
base path (e.g. C:\TheContainer\TheBaseFolder).

QO cClick [OK].

(] For Base URL enter the server name and Virtual
Directory name (e.g. http://vm-mobileed/

TheVirtualDirectory).

Fille Action Help

e Ead

=5

<

n ArcFM Geodatabase Replication Administrator*

=B " ArcFM Geodatabaze Replication
=1 CAnetpubhwwwioot\rcFMGDERe
=€ web Service

Gereral

[y TheReplicaName

Configuration Errors

EIBIX

E General
Replica Mame
Personal Geodatabase File Mame
Base Directary
Base UNC

TheReplicaName
Backdrop.mdb
C:ATheContainer\TheBaseF older

http://¥m-mobileedb/TheYirtualDirectory

Base URL
Specify the http path (http://Computert ame/Virtualt aseDin to your vitual directony
This path is required by clients using the BITS transport method.

Mame

| Property

Desoiption Path

Add a perzonal geodatabase replica web service

) From the File menu, choose Save All.

QO If any Configuration Errors appear at the bottom
of the window, resolve them.

L Once all errors are resolved, save the settings and
close the ArcFM Geodatabase Replication
Administrator.

When the Web Server is correctly configured, the Field Unit can view
the contents of the Enterprise Server base directory (using the Virtual
Directory) and access the Web Server’s replication services.

L On the Field Unit, open the Internet Explorer
web browser.

) Inthe Address bar, enter the Base URL - the same
URL you set in the ArcFM Geodatabase

ReplicationAdministrator (e.g.
http://vm-mobileed/

TheVirtualDirectory).
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vm-mobileed - /TheVirtualDirectory/ - Windows Internet Explorer

@. o = | &) hitp:fjvm-mobileed/ThevirtualDirectory v| 42| % L~

Eile Edt ¥ew Favorites Tools Help

2 o (2 - »
VP | @ vmemabieed - [TheViruaDirectory I fi - B - b - | page - G Tooks -

vm-mobileed - /TheVirtualDirectory/

[To Parent Directory]

Tuesday, September 16, 2008 5:23 PM <dir> InitialExtract
Tuesday, September 16, 2008 4:40 PM <dir> Logs
Tuesday, September 16, 2008 5:38 FM <dir> TheReplicaName

Done S Local intranet F100% <

L Once that web page loads successfully, test the service

The only part of the second URL URL (e.g. http://vm-mobileed/
that will change from one customer ArcFMGDBReplicationService/

to another is the name of the Web i - R
Server. The gdbreplicationwebservice.asmx).
ARCFMGDBREPLICATION

SERVICE web site is created when

the AI’CFM GDB Rep|lcati0n Web Z GDRepIimtianWebSe-rv‘ir,e Web Service - Windows Internet Explorer g@g‘

software is installed, and always WO~ Bl imadiestivcnstretan: B 31X 1D 2l

has the same name. File Edit View Favorites Tools Help = _ =
- B Y g v Page- Safety~ Took- @~

5. Favorites | & GDBReplicationVebService Web S... - B

| GDBReplicationWebService

The following operations are supported. For a formal definition, please review the Service Description.

+ GetDeltaFile

If the Replication and Web Servers Prepares differances for a replica based on an identifier
are separate (a distributed « getrulliatestrile
. . . . Prepares a full download for a replica
implementation), you will still use .

M . + ReportClientUpdateStatus
the Web Server’s name in both of Writes dlient update status to a log.
these URLSs. « validateReplicaNameExists

Validates that a replica name exists on the web.

% Local intranet da - H100%

tl p If a page does not load, enter the
same URL into a web browser on
the Web Server to see a more

detailed error message. Q) If either page does not load successfully, resolve the

problem before proceeding.

PART 4: CONFIGURING CLIENT-SIDE REPLICATION

STEP 1. CREATE THE FIELD UNIT BASE PATH

The Field Unit base path does not O on the Field Unit, create a new folder and su_bfolder
have to be identical to the at the top level of a drive (e.g. C:\TheContainer\

Enterprise Server base path. TheBaseFolder).
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STEP 2: SET FIELD UNIT PROPERTIES IN THE ARCFM
GEODATABASE REPLICATION ADMINISTRATOR

L still on the Field Unit, from the Start menu choose
Programs > ArcFM Solution > ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Administrator.

U From the File menu choose Open Configuration
File.

 Browse to Program Files\Miner and Miner\ArcFM
Solution\Bin\ReplicationConsole.exe.config.

QO click [ Open].

tIp Alternately, you could right-click U Select ReplicationConsole.exe.config in the tree.
ReplicationConsole.exe.config in the

tree to choose New > Client. i .
] From the Action menu choose New > Client.

a ArcFM Geodatabase Replication Administrator,

File | Action Help

?‘lj [ MNew » Client
= Server
5 __,EI._._..._. T B General

U For Client Base Directory browse to the Field Unit
base directory (e.g. C:\TheContainer\
TheBaseFolder).

O click [OK].

U Right-click General Category and choose New >
Personal (or File) Geodatabase Replica Client.

B ArcFM Geodatabase Replication Administrator* g@@
File Action Help
DeEd
= £ ArcFM Geodatabase Replication El CategorgName
=1 D:\Program Files\Miner and Minerid Category Mame General Category

= 8% Client
@

Directory Replica Client

Rename File Geodatabase Replica Client
Remave Personal Geodatabase Replica Client
Yalidate Cerl+Shift+y Process Framewark Replica Client

Mew Configuration File  Chrl+
Sawe Configuration File Chrl+3

The Replica Name must be U For Replica Name type TheReplicaName

identical on the Replication Server,
Web Server, and Field Unit for

replication to succeed. The Replica Name must be entered into the server

ReplicationConsole.exe.config, Web.config and the client
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ReplicationConsole.exe.config with exactly the same spelling. If the
Replica Name differs in any of these three locations, replication will fail.

O Verify that Enabled is set to True.

U For Personal (or File) Geodatabase File Name,
type Backdrop.mdb or Backdrop

Microsoft BITS technology U For Transport method choose Bits.
downloads files in the background
while the end user does not need _
the bandW|dth for Other taSkS. ’_nrcFM Geodatabase Replication Administrator,
BITS can also resume an Dedten it

" 5 tEEa
Inter_ruptEd (_10Wﬂ|03d InSte?d Of =-5] ArcPM Geodatabase Replication Fieplica Name TheReplicaName [=
Startlng aga"’] from the beg|nn|ng, =1 [ D:\Program Files\Miner and Miner\ | Enabled Triue
. = 8 Client Personal Geodatabase File Name Backdrop.mdb
unlike UnCCOpy. =1 Gereral Category Transport Method Bits

U Do not change the default values for any
Replica Update Settings.

tlp All slash (vir i
gule) characters in . .
A e Ay Q For the Web Service URL enter the service URL,
forward slashes, not back slashes. (e.g. http://vm-mobileed/

ArcFMGDBReplicationService/
GDBReplicationwebservice.asmx).

B ArcFM Geodatahase Replication Administrator g@@
File Action Help
heEdd
= B%] ArcFM Geodatabase Replication Feplica Name TheReplicaName BN
=[] D:\Program Files\Miner and Miner'd | Enabled Tiue
= 8% Client Personal Geodatabase File Mame Backdrop.mdb
=] General Categom Transport Method Bits
TheReplicalame El ReplicaUpdate Setiings
Update Interval [Days HH:M:55) 00:00:00
Number Of Retries 5
Number OF Retries For Full Downloads 3
Rty Interval [Daps.HH:MM:55) 00:15:00
El Replica®eb Service Setings
e UAL http:// bileed/arch
e Timeout [minutes) 00:05:00 =

) From the File menu, choose Save All.

QO If any Configuration Errors appear at the bottom
of the window, resolve them.

L Once all errors are resolved, save the settings and
close the ArcFM Geodatabase Replication
Administrator.

STEP 3: TEST THE FIELD UNIT CONFIGURATION

U still on the Field Unit, from the Start menu choose
Programs > ArcFM Solution > ArcFM
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Geodatabase Replication > ArcFM Geodatabase
Replication Client.

B ArcFm Replication Status E|§|@

TheR ephcal ame
Replication Complete
Statuz changed at: 10/14/2008 11:49 Ak

Last Update: 10/14/2008 11:43:41 &AM

(et

Q) If any errors appear, look in the Event Viewer for more
information. Any message requesting you retry
replication indicates an error. After making
corrections, you must exit and restart the client-side
replication process (not just choose Update Now) for
your changes to take effect.

L When replication succeeds without producing any
errors, observe that a Replica Name folder has been
created on the Field Unit (e.g. C:\TheContainer\
TheBaseFolder\TheReplicaName). Inside this
folder will be the Backdrop database. Do not open
this file!

PART 5: CONFIGURING THE LOGIN DATABASE

If implementing Redliner or Inspector, to allow field users to save
redlines (graphics and ink) in a Session/Design without requiring an
ESRI ArcEditor license, the Stored Display showing when a new
Session/Design is opened must include a layer from a feature class which
meets all three of the following criteria:

e |snotin a network
e AND is in a dataset that does not contain a network
e AND does not have feature-linked annotation.

To allow field users to store redlines in an ArcFM Annotation Feature
Class, this class must be included in the backdrop geodatabase in a
dataset of its own.

STEP 1. PREPARE THE DATABASE FOR USE

Telvent provides a sample Login database that you can tailor to fit a
client’s Mobile implementation. You will start by uncompressing the
sample Login database, then update it to ensure that it is compatible with
the current version of ArcFM.
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U On the Enterprise Client, double-click the sample
MinervilleMobileLogin_version.exe to unzip it.

QO click [Unzip].

L When the extraction is complete, start ArcCatalog.

WinZip Self-Extractor - MinervillaMobileLogin_9... []

Ta unzip all files in this self-extractor fle to the _
specified folder press the Unzip buttan,
Run Windip
bileS olution Erowse Close
v Overwrite files without prompting About
Help

O Using ArcCatalog, copy and paste the
By default, the self-extracting MinervilleMobileArcFMLogin.mdb database into
MinervilleMobileLogin_version.exe the Enterprise Server base directory (e.g.
places the extracted Z:\TheBaseFolder).
MinervilleMobileArcFMLogin.mdb
in C:\Program Files\
Miner and Miner\ArcFM RApCatalor SR EBX
Solution\Sample Data\ B2 BT S50 B mme LT S
MobileSolution. =25 o HEEE

Location ‘Z 3}

B Q& O k2

®

Contents I Previe 1 | *
[ Catalog Al
& [} _
= % z\ (1 TheBaseFalder
=-[_1 TheBaseFolder
¥ TnitiaExtract
¥ Logs
+-[_1] TheReplicaMame
Login
3 [g Database Connections v |< >

You may name the Login database

anything allowed by your U Rename this new copy of

operating system. The Login MinervilleMobileArcFMLogin.mdb if desired. In
database name will be visible to these checklists, the database will be called
field users. Login.mdb

If-your Stored Displays will be U Right-click Login.mdb and choose Create/Update

altered on an ongoing basis, ArcFM Solution System Tables.
consider creating folders on the

SUEGRTED SRR 2kl 15 (T O Right-click Login.mdb and choose
Units for directory replication.

Directory replication can Upgrade ArcFM Solution Database.

propagate updated copies of the
Login database to all Field Units.

STEP 2: CHANGE THE DATA SOURCE FOR STORED DISPLAYS

To delete a table, right-click over it U From the Login.mdb database, delete the following
and choose Delete. tables:
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MM_STORED_DISPLAYS
MM_SYSTEM_STORED_DISPLAYS
MM_PACKAGES
MM_SYSTEM_PACKAGES

¥ ArcCatalog - Arclnfo - Z:\TheBaseFolder\Login.mdb\MM_S.... [= |[B][X]

File Edit View Go Tools Window Help
= 5 Bt QDO N
Location: |Z:"-.TheBaseFoIder"'-.LDgin.mdb"-—.l‘v‘lM_SYSTEM_STORED_DISPLAYS

x| Corterts ] Previe 4 |
MM_PERSIST_INFO ~
MM_SNAPPING Name:  MM_SY’
MM_STORED_DISPLAYS Type:  Person
MM_SYSTEM_DOCUMENTS
MM_SYSTEM_PACKAGES
MM_SYSTEM_PAGE_TEMPLATES
MM_SYSTEM_PERSIST_INFO
MM_SYSTEM_STORED_DISPLAYS |'v

If using SQL Server, connect to the MMENG_ANCHORCAPACITY ] JE2 *
database that contains the MM
tables (usually ““sde”), not the
database that contains the feature
classes (usually “arcfm™).

O If including Page Templates in the Login database,
delete the tables MM_PAGE_TEMPLATES and
MM_SYSTEM_PAGE_TEMPLATES.

L Connect to the enterprise SDE geodatabase using
the sde database and sde.DEFAULT version, as
user sde.

U From the enterprise SDE geodatabase, copy the
following tables to the Login database:

MM_STORED_DISPLAYS
MM_SYSTEM_STORED_DISPLAYS
MM_PACKAGES

MM_SYSTEM _PACKAGES

U I1f including Page Templates in the Login database,
copy the tables MM_PAGE_TEMPLATES and
MM_SYSTEM_PAGE_TEMPLATES from the
enterprise SDE geodatabase to the Login
database.

Next you will create a testing copy of the base path for use in setting the
correct data source for all the layers of the Login database Stored
Displays. The testing base path must have exactly the same path as the
Field Unit base path.

0 still on the Enterprise Client, create a folder and
subfolder with identical names and drive locations as
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Do NOT browse to the Backdrop
geodatabase on the Enterprise Server
or Field Unit! If you do so, the data

source path will contain the Enterprise
Server or Field Unit machine name
(e.g. \\wvm-mobileed\TheContainer
\TheBaseFolder\InitialExtract) instead
of the local base path (e.g.
C:\TheContainer\TheBaseFolder\
InitialExtract). If the machine name is
hardcoded, the Login database will
only be usable on that one machine,
instead of on all Field Units.

Building Your Mobile
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the Enterprise Server Base Path (e.g. C:\
TheContainer \TheBaseFolder).

U Create a folder named for the Replica Name (e.g.
TheRepl icaName) inside the testing base path
(C:\TheContainer\TheBaseFolder).

U Using ArcCatalog, copy the Backdrop geodatabase
from the Enterprise Server base path
(Z:\TheBaseFolder\lInitialExtract) to the
Enterprise Client testing base path
(C:\TheContainer\TheBaseFolder\
TheReplicaName).

QO Right-click Login.mdb and choose ArcFM Data
Source Wizard.

QO cClick [ Next].
L Check the box for Stored Displays. If including

Page Templates, also check the box for Page
Templates.

-
i ArcEM Data Source Wizard

Select Stored Items

Select the ikems that should hawe their data sourd]

¥ Stored Displays
+- [] Documents
+-[JPage Templates
+-[JMap Books

Click [ Next].

Choose Set all data sources.

Click [ Next].

Choose Personal or File Geodatabase.

Click [ Choose data source... ].

o U0 0 0o

Browse to the Backdrop geodatabase in the
Enterprise Client testing base path (e.g.
C:\TheContainer\TheBaseFolder\
TheReplicaName\Backdrop).

QO cClick [OK].
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Set the Destination Data Source

Select the data source to which the layers will be connected when the update is
complete.

" ArcSDE Database

Server: |
Service: |
|

D=

Authentication: | J
{* Personal or File Geodatabase
Path:

|C.\TheCurrtainer\ThEBaseFuIdEr\ThE Replica Mame"Backdrop.mdb

Choose data source...

ﬂ ArcFM Data Source Wizard E

O Click [ Next].

Q) Verify that the path begins with the drive name (e.g.
“C:\” ) not any machine name (e.g. “\\vm-

mobileed”).

Summary

A& summary of the updates that will be made. %

“ou have chosen to changethe connection information for 12 stored displays, 0 documents, 0 page
templates and 0 map books.

All the layers will be set to the destination data source.

path: C:\TheContainer\TheBaseFolderTheReplicaName'\Backdrop.mdb

a ArcFM Data Source Wizard K

U Click [ Next] again.

U If prompted to connect to the enterprise SDE
geodatabase, connect to the sde geodatabase as
user sde using the sde.DEFAULT version.

L When the wizard is finished, click [ OK ].
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Implementation-Specific Steps

Applies to: Implementations allowing users to place graphics
Basic Redliner, Advanced Redliner, Inspector,
Mobile ArcFM, Mobile Designer

QO Right-click entSDEgdb and choose ArcFM Favorites.
O Export the Graphic Favorites.
U Right-click Login.mdb and choose ArcFM Favorites.

U Import the Graphic Favorites.

Implementation-Specific Steps

Applies to: Implementations allowing spatial edits
Mobile ArcFM, Mobile Designer

Right-click entSDEgdb and choose ArcFM Favorites.
Export the ArcFM Favorites and/or CUs.

Right-click Login.mdb and choose ArcFM Favorites.

(U R W

Import the ArcFM Favorites and/or CUSs.

(L On the Enterprise Client, start ArcMap.

U Inthe Login to ArcFM screen, log in to the Login
database in the Enterprise Server base path. The user
name does not matter.

U On the ArcFM toolbar, from the Stored ltems
menu, choose Stored Items Manager.
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Stored Displays with fewer layers
generally have better performance.

Building Your Mobile
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Stored Items Manager

Page Templates Stored Displays } Documents |
=|-{F System Stored Displays
@ Electric Only ﬂ ﬂ
& Gas only
R
4oy e
{1 User Stored Displays (arcfm) T
Close

L Remove any Stored Displays that field users will not
need.

O Click [ Close].

L For each of the Stored Displays that the field users will
need:

0 Make sure the Stored Display contains only the layers
field users will need. Remember to remove any
unnecessary non-spatial tables on the Table of
Contents > Source tab.

o If implementing Redliner, verify that each Stored Display
that could be used for redlining contains a feature class
that does not have feature-linked annotation AND is
from a dataset that does not contain a network.

o0 Make sure all of the layers point to tables included in the
Backdrop database in the testing base path.

o From the Stored ltems menu choose Save to save
your changes to the Stored Display.

QO If including Page Templates in the Login database, on
the ArckFM toolbar from the Stored Items menu
choose Stored Items Manager.

o0 On the Page Templates tab, delete any unneeded
Page Templates

o0 Test each remaining Page Template. Page Templates
which use external files (e.g. logo image files) may
display a broken link. Correct this by deleting the link,
then copying and pasting the image into the Page
Template instead of using Insert menu > Picture or
Insert menu > Object.
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Implementation-Specific Steps

Applies to: Implementations allowing users to place graphics
Basic Redliner, Advanced Redliner, Inspector,
Mobile ArcFM, Mobile Designer

U Display the Graphics tab (Tools menu > Options >
TOC tab).

U Confirm that the graphics you imported are present.

Implementation-Specific Steps

Applies to: Implementations allowing spatial edits
Mobile ArcFM, Mobile Designer

U Start Editing.

U Verify that the Feature Favorites and/or CU
Favorites you imported are present.

U Stop Editing.

U Close ArcMap.

Next you will share the Field Unit base directory in order to copy the
Login database from the Enterprise Server to the Field Unit.

U On the Field Unit, right-click the top base path
folder (e.g. C:\TheContainer) and choose Sharing
and Security.

U Check Share this folder on the network.
U Check Allow network users to change my files.
O click [OK].

U On the Enterprise Client, map a drive to the Field
Unit folder (e.g. C:\TheContainer).

[ still on the Enterprise Client, using ArcCatalog, copy
the Login database from the Enterprise Server base
path to the Field Unit base path (e.g.
C:\TheContainer\ TheBaseFolder).
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STEP 3 TEST THE LOGIN DATABASE

A field user views geodatabase data by connecting to the Login database
and applying a Stored Display. The Stored Display retrieves data from
the Backdrop geodatabase for display to the user. In this step you will
use the ArcFM Engine Administrator to create and test the Login
connection, then test each Stored Display.

Implementation-Specific Steps

Applies to: Implementations on the ArcMap platform
Mobile ArcFM, Mobile Designer

U On the Field Unit, start ArcMap.

O In the ArcFM or Designer login screen, browse to the Login
database.

L Test that all layers of all Stored Displays appear
correctly.

(L Test that all Page Templates appear correctly.

L Do NOT start editing. Never edit the Backdrop database
directly.

Q Skip all instructions below regarding the ArcFM Engine
Administrator and ArcFM Viewer for ArcGIS Engine
and jump to the next step.

] On the Field Unit, run Start > Programs >
ArcFM Solution > ArcFM Engine Administrator.

U Display the Login tab.

QU Right-click Login Connections and choose
Add Connection.

= ArcFM Engine Administrator

J/ Login % Layout and Licenses

E3l | ogin Connection

Add Connection
Mame:

Geodatabase:

L On the right side of the window, for Name type a
connection name for future use by end users (e.g.
CourselLoginConnection).
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=

= ArcFM Engine Administrator

/ Login % Lapout and Licenses \

= Login Connections
Marquette_ORACLE

= Elmo_DIRECTCONNECT M ame: CourzeloginConnection
tl p If ArcGIS Desktop is installed on the pinenlend Geodatehase:
. . ) celot_SOLServer Path
Field Unit, you will see the Select CouseLoginComnection

New Database Connection
dialog instead of the
Geodatabase Properties
dialog. Regardless of which dialog
you use to specify the Login
database, the resulting connection

will be the same. U Under Geodatabase, click [ Browse ].

U From the DBMS Provider drop-down choose MS

Selecl New Dalabase Conneclion

Lockin: |0 TheRaseFolder v| 2 ++| 1|38 ACC@SS
| Mo Tyos
I Therepkcabisme Folder

Prrsonal Gendakahase

U Inthe Path field enter the path to the Login
database on this Field Unit (e.g. C:\TheContainer\
TheBaseFolder\Login.mdb).

Hame: Lognumd o ]
Show of e | Gecutalabazes w Carcel
Geodatabase Properties &l
DBMS Provider: | MS Access b
Server:
Service:

Path:  |C:\TheContainer':TheBaseFolder'\ Login mdb

QO click [OK].

Do NOT connect to the Backdrop database using this tool. Instead, the
Stored Displays in the Login database will point to the Backdrop
database.

2 ArcFM Engine Administrator

/ Login X Layout and Licenses "'-‘_

= Legin Connections
Marquette_ ORACLE

Smo_DIRECTCONNECT Name: CourseLoginConnection
gmnalwi";gf: Geodatabase:

celol_3Q Server Path: C:\TheCortainer' The BaseFolder\Login mdb
CourseLoginConnection

Process Framework:
Connection String

Help [ ok [ cancel |[ v

Ready
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Do NOT enter any information in the Process Framework (PX) area.
You will create and configure the field Process Framework database in a
later exercise.

L Inthe ArcFm Engine Administrator window, click
[ Apply 1.

U Display the Layout and Licenses tab.

U

In the tree on the left, select Licenses.

L In the licenses list on the right, verify that only the
licenses which will be available to this machine are
checked, and that all licenses necessary to run the
software are checked.

O click [OK].
0 still on the Field Unit, run Start > Programs >
ArcFM Solution > ArcFM Viewer for ArcGIS

Engine.

U Log in using the newly-created connection to the Login
database. The user name does not matter.

ArcFM Viewer for ArcGIS Engine

™

rc
SOLUTION

é 5

CoumelognCennection -

Ctabse
Tl ot e, Thn s ok L ek

U From the Stored Display menu, apply each Stored
Display and look for any broken layers (identified with
a red exclamation mark).

% Data View - ArcFM Viewer for ArcGE Fngine

t| p To locate an edited feature, from the e [ e— e :
View menu choose ArcFM Locator. Desopur sty | Daaviow | %
From the Locator Tool drop-down, il Fowping
choose Attribute Query. From the Gy

Search drop-down, choose the desired
feature class. Enter the feature’s

enterprise SDE geodatabase ObjectID . . .
into the ServerolD field, theniclick Q if you included Page Templates in the Login

Find. database, test each one by choosing File > Print.

If there are any problems with any Stored Displays and/or Page
Templates, correct them by opening ArcMap on the Enterprise Client
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and making the necessary changes to the Enterprise Server Login
database Stored Displays and/or Page Templates. Close ArcMap, use
ArcCatalog to re-copy the Login database from the Enterprise Server to
the Field Unit, and re-test the altered Stored Displays and/or Page
Templates.

Once your Stored Displays display correctly, you may also locate the
features you edited in the enterprise SDE geodatabase to verify that the
edits you made have been applied to the Field Unit Backdrop
geodatabase.

PART 6. ADDITIONAL TASKS

U For all implementations using ArcFM Viewer, use the
ArcFM Engine Administrator to configure ArcFM
Viewer interface settings (toolbars, dockable windows,
etc.).

U Configure Directory Replication (ideally including
the Login database) if desired.

CHECKLIST END
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