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MOBILE CHECKLIST B. CONFIGURE REPLICATION

IMPORTANT: Before beginning the Mobile configuration process, complete all

items listed in Mobile Checklist A: Preparation.

In these steps, the Enterprise Server (file hosting), Replication Server, and Web
Server are distinguished. If you are working on an ideal setup, where all three
servers are actually the same machine, then apply all instructions given for any of

the three servers to your unified server.

PART 1.: CONFIGURING SDE AND THE BACKDROP DATABASE

STEP 1. PREPARE THE ENTERPRISE SDE GEODATABASE

For an SDE geodatabase to act as the final authority on all data involved
in a Mobile implementation, the SDE geodatabase must first be
compatible with the version of ArcFM currently installed. The tables
and fields within the SDE geodatabase should be assigned the necessary
ArcFM model names before any other Mobile databases are created.

L On the Enterprise Client Configuration Machine, run
Start > Programs > ArcGIS > ArcCatalog.

0 In the ArcCatalog tree on the left, expand Database

Connections.

U Double-click Add Spatial Database Connection
and enter all connection information.

U Uncheck Save the transactional version name

with the connection file.

Spatial Database Connection Properties @
Server |vm-mub\|eed
Service: |5'\ g1
Database: |sde
(If supported by your DBMS]
Acount
¥ Database authentication
Username: |sde
Password: |
V¥ Save uzemame and password
" Dperating spstem authertication
Connection details
The follawing transactional version will be used
|sde DEFAULT Change...
[ Save the ransactional version name with the connection file.
Test Connection Cancel
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Unchecking the option to save the transaction means that every time you
connect to the enterprise SDE geodatabase, you will be prompted to
choose a version. Choosing the correct version each time is essential to a
successful Mobile implementation. At key moments, connecting to the
wrong version could create problems significant enough to require
redoing much work. For example, when copying data into the new
Backdrop database, it is essential to connect to the InitialExtract version,

The simplest arrangement is for not the Sync version.

SDE to own the Sync version

and the InitialExtract version.

'I*‘_’t"_"elvéfvt anyt YR IEY °‘|"’” the U Verify that the version is the Sync version (typically
nitial Extract version as long as sde.DEFAULT).

the Replication Server is given the
correct user name and password

to access it. Q click [ OK].

This connection will be referred to as the entSDEgdb connection for the
remainder of this checklist.

Even if the enterprise SDE geodatabase is up-to-date, running Upgrade
ArcFM Solution will not harm the database, but will ensure that it is
compatible with the currently installed version of ArcFM.

Depending on the version of O Right-click the entSDEgdb connection and choose
ArcFM and the permissions Upgrade ArckFM Solution Database.
granted to user sde, you may need

to run Create/Update ArcFM .
Solution System Tables and O when the Upgrade ArcFM Solution Database

Upgrade ArcFM Solution prompt appears, click [ Yes ].
Database as user sde, then again
as user ArcFM. See the version-

specific “What’s New”” section of Next you will update the MM system tables. The Create/Update ArcFM
Configuring the ArcFM Solution Solution System tables command will not alter any data in the MM
help for details. tables, but will ensure that the tables have the correct structure.

U Right-click the entSDEgdb connection and choose
Create/Update ArcFM Solution System Tables.

L When prompted to choose a version, choose the Sync
version.

0 Assign the model name MM ENTERPRISE to the
enterprise SDE geodatabase.
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Implementation-Specific Steps

Because the ArcGIS Utility
Network Analyst extension is not
available in ArcGIS Engine,

Telvent created its own tracing Applies to: All ArcFM Viewer-based implementations
support extension for use in View-Only, Basic Redliner, Advanced Redliner, Inspector

ArcFM Viewer for ArcGIS Engine.
This code relies on these model )
names. When implementing L To each electric edge feature class

Mobile ArcFM or Mobile (PriOHElectricLineSegment, Bus Bar,

Designer, you do not need to LT .
assign the network edge model SecondaryUGElectricLineSegment, etc.) assign the

names because ArcFM and ELECTRICNETWORKEDGE model name.
Designer use ArcGIS Desktop
(ArcMap) instead of ArcGIS
Engine.

U To each gas edge feature class (DistributionMain, etc.)
assign the GASNETWORKEDGE model name.

L To each water edge feature class (WDistributionMain, etc.)
assigh the WATERNETWORKEDGE model name.

STEP 2: CREATE THE INITIALEXTRACT VERSION

The InitialExtract version marks a key moment in the life of the
enterprise SDE geodatabase. All edits made to the Sync version before
the InitialExtract version is created will be included in the Backdrop
geodatabase. All edits made to the Sync verison after the InitialExtract
version is created will not be included in the Backdrop geodatabase.
These later edits will be added to the Backdrop geodatabase through
replication after the Backdrop has been moved to the Field Unit.

The sync version (normally . . .
n DEFAULT) must be the parent of O Right-click the entSDEgdb connection and choose
the InitialExtract version. The Versions.
version you right-click over before
choosing New will be the parent of . . . .
the new version. O In the Version Manager window, right-click over

DEFAULT and choose New.

tl p A version name that begins with an = Version Manager (sde on vm-mobileed) @E
underscore will appear toward the (Name  |owner  |Access | lastModied |
top of any forward-sorted version = PLblic 9/5/2008 10:...
list. If you do choose to start the Rename
version name with an underscore, Delete
remember to include that Refresh
underscore in every property field Propertics...

you encounter that requires the
Initial Extract Version name.

Building Your Mobile Mobile Checklist B: Configure Replication - 5
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L For Name enter InitialExtract
U For Description type Do not delete

(] Set Permission to Private.

Mame

. ) |_Initia|E:<tract
After Mobile is running
successfully, you can delete the Description
InitialExtract version. DO WOT DELETE
However, if this version is deleted
before the first replication server
(Replica Build) process runs, you
will have to redo much of your Flenilkssfa
configuration work, including & Private
creating a new Backdrop
geodatabase. & Public

" Protected
Cahicel
QO cClick [OK].

U Close the Version Manager window.

The InitialExtract version should be used only at the proper times during
replication configuration and initialization. To double-check that
InitialExtract will not be the default connection version you will revisit
the enterprise SDE geodatabase connection properties.

U Right-click the entSDEgdb connection and choose
Connection Properties.

O Verify that Save the transactional version name
with the connection file is NOT checked.

Connection details
The follawing transactional version will be used:
|sde.DEFAULT Change..
I I Save the lransactional vession name vath the cornection file I
Test Connection Cancel
QO cClick [OK].

Building Your Mobile
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STEP 3: CREATE THE BACKDROP GEODATABASE

You will create the Backdrop on the Enterprise Server, from which it
will be copied during the first replication client (Update Request) process
run on each Field Unit.

=3 Ll o iie SariEE: Optipnal: If implementing Redliner or Inspet_:tor,
Folder button on the Standard and intending for field users to have the option of
toolbar. saving redlines (graphics and ink) in an ArcFM

Annotation Feature Class, this class must be in a
separate dataset of its own, and must be included
in the Backdrop geodatabase. If there are multiple
ArcFM Annotation Feature Classes, they can all be
in the same dataset.

U Click the Connect to Folder button and create a
connection to the Enterprise Server base path. In
these steps, it is assumed that the Enterprise Server
base path will be accessible from a mapped drive Z:.

Connect to Folder @E

Choose the folder to which you want to connect:

i

=l [} Desktop

H-{_} My Documents

=] _é My Computer
+]- g Local Disk (C:)
+-2 DVD/CD-RW Drive (D2)
o2
+-{3) Shared Documents
+-{3) train's Documents

+ ‘_f My Metwork Places

+{) Course Data

OK ] [ Cancel

QO click [OK].
U Expand Z: and TheBaseFolder.

U Right-click InitialExtract and choose New >
Personal Geodatabase or File Geodatabase.

(J Name the new geodatabase Backdrop

Building Your Mobile Mobile Checklist B: Configure Replication - 7
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Do not open the Connection
Properties in order to check
whether you are connected to
Initial Extract. Because we are
keeping Save the
transactional version name
with the connection file
unchecked, the Connection
Properties will always revert to
DEFAULT upon opening.

tip

Most Servers and Field Units will
not have ArcGIS Desktop software
installed. Therefore, any
operations requiring ArcCatalog
will be done by running
ArcCatalog on the Enterprise
Client and then opening a
connection within ArcCatalog to
the Server or Field Unit base path.

tip

Building Your Mobile
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-3 ArcCatalog - ArcInfo - Z:\TheBaseFolder\InitialExtract

File Edit View Go Tools Window Help

| E3 K e B2 QSO N

Location: ‘Z “\TheBase Folder'Initial Extract

Styleshest:

X| Conterts I Preview ] Metadata ] Mode! Names 1
[l Catalog L)
& @ = Mame | Type
T

= TheBaseFolder
23 InitialExtract
=I-(2 Database Connections
23 Add OLE DB Connectior
23 Add Spatial Database €
-1 entsDEgdh
(5 Database Servers v
< >

Personal Geodatabase

Personal Geodatabase selected

U Right-click the entSDEgdb
Disconnect.

U Right-click the entSDEgdb
Connect.

connection and choose

connection and choose

L When prompted to specify a transactional version,

choose sde._InitialExtract.

Be very careful to choose the InitialExtract version! InitialExtract marks

a moment in time shortly before the creation
geodatabase. After the Backdrop is in place

of the Backdrop
on the Field Unit, any edits

made to the sync version after the InitialExtract version was created can
then be applied to the Backdrop database, bringing it up to date again.
However, if the Backdrop is created from some other version, important

edits might be missed in the first update, and
users.

O cClick [OK].

will never reach the field

( Copy the desired datasets and feature classes from the

entSDEgdb connection into

Backdrop using either

copy and paste or a schema and extract template.

Telvent recommends copy an

d paste.

U Right-click Backdrop and choose Create/Update
ArcFM Solution System Tables.

U Right-click Backdrop and choose Upgrade ArcFM

Solution Database.
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Next you will copy critical ArcFM properties (model names, shapping
settings, etc.) from the enterprise SDE geodatabase into the

Backdrop.mdb geodatabase.

U Right-click the entSDEgdb connection and choose

ArcFM XML Export.

U Connect to the Sync version if prompted.

O When the ArcFM XML Export window opens, check

all options.

L) Choose a convenient location for the file.

B9 ArcFM XML Export

Q E=part.

ArcFM Properties
ArcFM Relationship Class Info

Thiz tool allows you to export the selection to an XML file,
Pleaze select the type of information to export and click,

[ ArcFM Model Mame Information # Frogress

3

ArcFM Snapping Information
_— . e

< >
Export

W

File to contain the exported data:

|C:\AICFM data from enterprize SDE. =ml

[ Apply Style Sheet

Brawse

[ e

Export |

Cancel |

QO click [ Export].

O If prompted to export another file, choose [ No ].

ArcFM XML Export

U Right-click Backdrop.mdb and choose ArcFM XML

Import.
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BB ArcFM XML Import X

Thiz tool will allow pou to populate the selected

geodatabaze with infarmation contained in an x<kL

D:> file. Please choosze an option below and click lmport.
Options Progresz
v Ovenarite

" Keep Existing

" Prompt

Impart
FML file bo import:

|E:\ArcFM data from enterprise SDE.xml

[ Apply Style Shest

Impart | Cloze |

O Choose Overwrite.

0 Browse to the file you just exported.

Q click [ Import].
You may choose to see a list of information that was not imported. Since
the Backdrop database contains fewer tables than the enterprise SDE

geodatabase, many of the enterprise properties will not apply to the
Backdrop.mdb.

U If prompted to import again, choose [ No ].

ArcFM XML Import

Next you will add the Set ServerOIDs command to the ArcCatalog
interface and run it. If you used the schema and extract template method
to populate the Backdrop database, you do not need to run Set
ServerOIDs.

] From the Tools menu, choose Customize.

O Inthe Customize dialog, choose the Commands
tab.
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This step may take 30 minutes to
several hours.

Building Your Mobile
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U Inthe Categories column on the left, choose
ArcFM Solution.

Customize

Toolbars Commands l Optionz ]

Show commands containing: |
Categories: Commands:
3D View ~ g'."JAbout ArcFM Solution ~
ArcLatalo ? ArcFM Data Source Wizard
' ArcF Favorites
@ ArcFM Geodatabaze Estraction
‘ff ArcFM Orphaned Wersions Clear

ArcfGlS 8% Cotvversion T ools
ArclGlS 8« Data Management Tools
ArclGlS Servers

ArcGlS Servi

A:ETDdbDE;VICE 5 &ucFM Properties Manager
Cadastral A QIDs

Case Tools ¥ | ™ ArcFM Shanoing Manader ¥
< > <

[rezcription
Savein: |Maormal gxt - Keyboard... | Add from file... | Cloze |

U From the Commands column on the right, click and
drag ArckFM Set ServerOIDs onto any toolbar.

FolderlMnitialExtract\Backdrop.mdb

a & :04 k? ArcFM Set ServerQIDs
ckdrop.mdb j

Contents ]F‘review] Metadata | Madel Names |

U Close the Customize dialog.
O In the ArcCatalog tree, select Backdrop.mdb.
O Click the new ArcFM Set Server OIDs button.

L When the Successfully Set ServerOIDs message
appears, click [ OK].

ArcFM Set ServerOIDs El

\lr) Successfully Set ServerOIDs,
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ArcFM relies on model name assignments to determine what roles each
database, table, and field will play in the GIS. The MM FIELD EDIT
database model name indicates that a database will act as the backdrop.

Q Right-click the Backdrop database and choose
ArcFM Properties Manager.

U Choose the Model Names tab.

tIp The ArcFM Properties 0 Assign the MM FIELD EDIT model name to the
Manager will be disabled until
Create/Update ArcFM Solution Backdrop database. If any other model names are
System Tables and Upgrade assigned to this database, unassign them.

ArcFM Solution Database have

been run on the database. :
ArcFM Properties Manager EJ

Underground Facilties Mode! Names l

Model Mames
Model Mame Domain: |Domain Independent Database Model Nej
Model names available: Model names selected:
M FIELD EDIT Mk FIELD EDIT
»
b
< ¥

QK | Cancel Apply

QO click [OK .

PART 2: CONFIGURING THE REPLICATION SERVER

STEP 1: SET SERVER PROPERTIES

If the ArcEM Geodatabase L On the Replication Server, from the Start menu
Replication Administrator choose Programs > ArcFM Solution > ArcFM
command appears twice in the Geodatabase Replication > ArcFM Geodatabase

Start menu, you can launch the
application from either listing. On
the classroom server, it appears
twice because the Replication Web U In the ArcFM Geodatabase Replication Administrator,
and the Replication Server from the File menu choose Open Configuration
software have both been installed .

on the same server (this is the ideal File.
arrangement). If desired, you may
remove either command from the
Start menu.

Replication Administrator.

Building Your Mobile Mobile Checklist B: Configure Replication - 12
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ReplicationConsole.exe.config is
an XML file listing all the
Replication Server properties
which can be set and providing
some default values for them.
Sample.Server.ReplicationConsole
.exe.config is an XML file listing
the same Replication Server
properties, but with examples
provided for all values.

To register a new ESRI license
file (.ecp), run Start > Programs
> ArcGIS > Software
Authorization. Choose “I have
received an authorization file from
ESRI and am now ready to finish
the registration process” and click
Next. Choose “I received the
authorization file by email and
have saved it to disk." Click the
Browse button and locate the .ecp
file. Click Next. Click Finish. The
next time you open the ArcFM
Geodatabase Replication
Administrator, it will recognize the
license(s) granted in the chosen
.ecp file

Building Your Mobile
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’E Action  Help

Mews Configuration File  Ctrl+h

Open Configuration File  Cerl+-Shift+0
Saye Configuration File  Chl+5
Save gl CErlEhift+S

= [Mame]
Narne ArcFM Geodatabas

Exit

O Browse to C:\Program Files\Miner and Miner\
ArcFM Solution\Bin\
ReplicationConsole.exe.config.

O In the tree on the left side of the ArcFM Geodatabase
Replication Administrator, right-click over
ReplicationConsole.exe.config and choose New
> Server.

wnrcFM Geodatabase Replication Administrator®
File #Action Help

= ==

E General
ConfigurationFile C:\Program Files\Miner and MinertArcFM Solution®,
Client

Remarme: Server
Web Service

New Configuration File  Chrl+N
Save Configuration File Ctrl+5

Q) On the right side of the window, under General, click in
the Server Base Directory field.

nnrcFM Geodatabase Replication Administrator®
File Action Help

e Ed

E|---?-'-'; Aok Geodatabase Replication
E!I:l C:"Pragran Files\Miner and Mine
=3 J Server

“.|_] General Category

El General

ver Base Directon ]

= License Settings
ESRI License

ArcEditor

U Click the Browse (three dot) button to browse to the
Enterprise Server base directory, e.g.
C:\TheContainer\TheBaseFolder. Do not browse
to any directory within it.
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Browse For Folder [ 7] %]

=3 Instal -]
£ Licenses

(3 mssql

3 Program Files

23 Pythonzs
() Scripts

Bl & TheContainer

) InitialExtract
) WINDOWS
1 s |

Make New Falder | ok | caneel |

4

L Set the ESRI and Telvent licenses to match your
available licenses.

ArtFM Geodatabase Replication Administrator®

Ele Action Help

U
&) AcFM Geodatabase Replication E General
=1 C:\Program Fileshiner and biner! Server Base Dirsctony C:\TheContainer\TheBaseFolder
=] J Server B License Settings
-+{_] Gereral Categomy ESRI License Geodatab Update E

Telvent Miner & Miner License Engine Yiewer
Telvent Miner & Miner Extension Licenzes ArcFM Engine Editor Extension ;I

] From the File menu, choose Save All.

QO If any Configuration Errors appear in the lower

VO CTIII S UEREEy part of the dialog, resolve them before proceeding any
Telvent licenses are available, .

run Start > Programs > ArcFM further. If there are license errors, you may not be
Solution > License Manager > able to save your settings until the licenses are

Desktop Administrator. registered in the ArcGIS Software Authorization or

ArcFM Desktop Administrator tools.

Configuration Emmors
Mame | Property | Description | Path |
Server GlobalServerRe...  EsiiLicense <esriLicenseProductCodedrcEditor> is not ava...  C:\Program Files...
Ready 4

STEP 2: SET REPLICA PROPERTIES

Now that you have confirmed access to the necessary licenses, you will
declare the locations of critical folders and databases and give a hame to
this replica — the entire system of enterprise base path, Backdrop
geodatabase and enterprise SDE geodatabase used to provide updates for
specific tables or geographic areas to field users. These steps show how
to create and configure only one replica, but you may repeat them with
different replica names to create replicas for data that update at different
intervals (e.g. landbase vs. facility) or for distinct geographic areas

Building Your Mobile Mobile Checklist B: Configure Replication - 14
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Categories are used to organize
multiple replicas, much like folders
are used to organize multiple files.
If you only have one replica, the
Category Name does not matter. If
desired, you may rename the
General Category by selecting it in
the tree on the left, then changing
the name on the far right.

If the Backdrop geodatabase were
a file geodatabase, you would
choose New > File
Geodatabase Replica instead.

You can temporarily set Enabled
to False in order to prevent
replication from running.

Building Your Mobile
Copyright © Telvent

(service territories, counties, etc.), allowing field users to subscribe only
to the replicas they need.

L In the tree on the left, select General Category.

O From the Action menu, choose New > Personal
Geodatabase Replica or File Geodatabase
Replica depending on which type of Backdrop you
created.

ArcFM Geodatabase Replication Administrator*

File | Action Help

Directory Replica

Rename File Gendatabase Replica

Remove Personal Geodatabase Replica
Walidate Ctrl+Shift+y Process Framework Replica Server

General Category

L On the right side of the window, for the Replica
Name enter the replica name (e.g.
TheReplicaName).

ﬂnrcFM Geodatabase Replication Administrator®

Eile Acktion Help

e Ed

E|---'.‘v'-_'; ArcFM Geodatabasze Replication E General

E||:| C:MProgram Files\Miner and Mine Replica Nams TheReplicaName
EJ Server Description
E|{:| General Category Enabled True
EL' TheR eplica ame Personal Geodatabase File Name

The Replica Name matches the Field Unit’s files with the appropriate
information on the Web Server and Replication Server. If the Field Unit,
Web Server, and Replication Server have any difference in Replica
Name, replication will not work. Therefore, give the replica a simple
descriptive name and make sure to use the same Replica Name when
configuring the Web Server and Field Unit.

Q) If desired, type a description into the Description
field.

O Verify that Enabled is set to True.

U For Personal (or File) Geodatabase File Name
click the Browse (three dot) button.
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B Arcr™ Geodatabase Replication Administrator*
File Action Help

I[=] B3

e g
E|---3-‘-_: ArcFM Geodatabase Replication E General 1=
E||:| C:Pragram Filesiiner and Mine Replica Mame TheReplicaN ame
E|J Server Description
(=] General Categary Enabled True
@ TheReplicaMame *erzonal Geodatabaze File Mame
Initial Estraction Directary
= ArcSDE Settings

U Browse to the Backdrop database (e.g. in

C:\TheContainer\TheBaseFolder\InitialExtract).

O Click [ Open ].

wnrcFM Geodatabase Replication Administrator®

File Action Help

te  Ed

E|---?-‘-_‘: ArcFM Geodatabase Replication E General 1=
E||:| C:%Program FilesiMiner and Mine Replica Mame TheReplicaName
= J Server Description
=] General Category Enabled True
Eh TheReplicabame Perzonal Geodatabasze File Name Backdrop.mdb _I—

Initial Extraction Directory
= ArcSDE Settings

U For Initial Extraction Directory, click the Browse
(three dot) button.

U Browse to the InitialExtract folder (e.g.

C:\TheContainer \TheBaseFolder\
InitialExtract).

Be sure to browse only to the InitialExtract directory, not to any specific
file, or this value will cause an error when you later try to save.

Browse For Folder

= Tnstall |
) Licenses

I) mssql

) Program Files

I5) Pythonzs
) Scripts
= @2 TheContainer

= ) TheBaseFolder
R I1tialE b act
L) WINDOWS

=5 b =
Make MNew Folder | oK I Cancel |

O click [OK].

Mobile Checklist B: Configure Replication - 16



ﬂnrcFM Geodatabase Replication Administrator®

File Action Help

e Ba
E|--f-‘_': ArcFM Geodatabase Replication E General =
E||:| C:Program Files\Miner and Miner Replica Mame TheReplicaName
EJ Server Description
=+ General Category Enabled True

Eb TheReplicaName Personal Geodatabase File Mame Backdrop.mdb | |
Initial Estraction Directony C:ATheContainerTheB aseF olderInitialE xtr _|

When set to True, Compress
decreases the FGDB size. O If Backdrop is a file geodatabase, set Compress

However, this process may take . .
o e s s%t Compregs to to False. There is no Compress setting for a PGDB.

False while testing, then change it
to True when testing is complete. U For Server enter the ArcSDE Server name

e.g. vm-mobileed).

L For Instance, Database, User Name, and
Password enter the same values you used in the
ArcCatalog Spatial Database Connection Properties. A
Database value is only necessary if the enterprise SDE
geodatabase is a SQL Server database.

Spatial Dalabare Corr=riian Properiies

[ i

B Goneral

Fieplca Hame TheRepbtd ame

Descaphon

Erabled Toan

Perzonal Gecdstshase File Name Backdiop. mdb

Irabaal £l gctan (D wecl ity E. afieei T el as el abied ] natialE =i
B ArcSDE Settings

Servel wim mihileed

Inslance a5l

D alsbase sche lJ

e

O For Initial Extract Version specify the geodatabase
version from which the tables in the Backdrop
geodatabase were copied or extracted (e.g.
SDE._InitialExtract).

U For Sync Version specify the parent of the

set to False, the Initial Extract

vz cialll o e e U For Keep Initial Version choose True.
immediately after the first
replication process (Replica Build)
occurred. Normally, it is safer to
keep the Initial Extract version

through the first few replication . .
runs just in case reinitializing O For Email SMTP Server enter an email server

replication becomes necessary. accessible from the Replication Server (formatted as
sundance.miner.com).

U

Scroll down to Email Settings.
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] For Email Address enter the email address of the
administrator for this Mobile implementation.

U Change any other settings as needed.
L) From the File menu, choose Save All.

QO If any Configuration Errors appear at the bottom
of the window, resolve them.

L Once all errors are resolved, save the settings and

close the ArcFM Geodatabase Replication
Administrator.

STEP 3: RUN ARCFM GEODATABASE REPLICATION SERVER

If an error appears the first time Q) still on the Replication Server, from the Start menu
you run ArcFM Geodatabase choose Programs > ArcFM Solution > ArcFM
Replication Server, try Geodatabase Replication > ArcFM Geodatabase

running it again. Replication Server.

This calls ReplicationConsole.exe, which runs the Replica Build portion
of the replication process.

IS B3

e :ArcFM Replication Status

TheR ephcalame
Bootstrap
Statuz changed at 10/3/2008 317 AM

Update Howl

If any errors appear in the ArcFM Replication Status box, note and
resolve them before proceeding. You can also check the Event Viewer
for more details on any errors.

STEP 4: TEST REPLICATION

Next you will edit the Sync version to test whether the Replica Build
process will successfully identify the edits and extract them for use in
Field Unit updates.

L On the Enterprise Client, start ArcMap.
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L Inthe ArcFMm Login screen, browse to the
entSDEgdb spatial database connection.

O When prompted, choose the Sync version. If this is
not permitted, choose a child version of the Sync
version, then remember to reconcile and post the child
version to the Sync version before you run the server-
side replication (Replica Build) process again.

U Apply a Stored Display.

L On the Table of Contents Source tab, verify that the
current version is correct. If necessary, change the
version on the Source tab by right-clicking the
connection and choosing Change Version, then
choosing the correct version from the list that appears.

-l £F Layers A
= B sde.DEFAULT {vm-mabileed)
= E arcfm.ARCFM. GasDataset
# [ Meter Setting
# [ P Anods
& Distribution Main ™
< >

Display  Source | Selection | Features | Clls

Be absolutely certain you are not editing the InitialExtract version!

] From the Editor toolbar, Editor menu, choose Start

Editing.

Editor = Il |
The ArcFM method of sketching a ¥ Start Editing ‘
point feature is to click the feature
on the Table of Contents
Features tab, enter any required o
attributes on the ArcFM O Sketch a new feature on the map. Zoom in if
Attribute Editor Targets tab necessary.

(available from the ArcFM
toolbar), then click on the map to

place the feature. 0 Using one of the Identify tools, click on the new

feature to view its ObjectID.

U Note the Feature Class and ObjectID here:

When you next run replication (Replica Build), you will need this
ObjectID to determine whether the new feature was recognized as an
edit.
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] From the Editor menu choose Save Edits.

| Editor * b &~ Task |Create ArcFM Featur

BF Stop Editing
B Save Edics

U From the Editor menu choose Stop Editing.
U Close ArcMap.

O If prompted to save changes to Untitled, choose
[ No].

L On the Replication Server, from the Start menu
choose Programs > ArcFM Solution > ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Server.

O In the Enterprise Server base directory, browse to the
new Replica Name folder (e.qg.
C:\TheContainer\TheBaseFolder\
TheReplicaName) and open the new
Extract_<date time> folder inside.

U Inthe Extract_<date time> folder, open the
XML file and confirm that your new feature is listed.

t i {2 C:\Documents and Settings Administrator'Desktop)_InitialExtract.xml - Windows Int... [H[=][E3
p The XML file in the Extract o = [ caporuments and settngsiadnz] |42 || % | [[ve seven ol

folder lists any edits recognized by Hle Edt Vew Favorkss Tods bep

the replication software as having U0 @ C\Documents and settngsladminstr... ‘ | £ - B - 8 - [shpace - @hTock -

been made after the previous <l version="1.0° 7> il

replication run (Replica Build). o e

The XML file will not include edits - ceditiog>

- - - — SE5SIonz
captured during previous Replica <entrycounts1e/entrycounts
i i i = table="arcfm.ARCFM.CPANode" 0id="6214" suroid="0"

Builds. After its creation, the XML S e noae s =

1 1 field ="ANCILLARYROLE" t ="null" /-

file is not accessed by any Sfeld namo—"COMMENTS" type—tnull /o

repllcatlon process so you may <fizld name="CPRECTIFIERCABLEOBIECTID" type="null" />

<field name="CPSYSTEMOBIEGTID" type="null" />

view it without interfering in future
replication. All other files in the
Extract folders must not be opened,

or you will have to build and O If the XML file does not list your newly created feature,

LGS T L) then replication did not succeed. Check the Event

geodatabase and restart . . .

replication. Viewer for error information, resolve any errors, and
run ArcFM Geodatabase Replication Server
again.

L Once replication recognizes your new feature, test
each of the following edit types. You can test them all
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in one Replica Build, but make sure that all five types
of edits do appear in the resulting XML file. For
example, you may find that attribute updates are
recognized while feature deletions are not, in which
case you will need to resolve this error before
proceeding. Remember to save edits, stop editing, and
close ArcMap before running the ArcFM Geodatabase
Replication Server command.

Edit

Feature
Class

ObjectID Details

Insert a feature

Delete a feature

Update an
attribute

Changed attribute

from value
to value

Relate a feature to
an object

Object Class

Object’'s OID

Unrelate a feature
and an object

Object Class

Object’'s OID

PART 3: CONFIGURING THE WEB SERVER

IMPORTANT: These Web Server configuration instructions assume that
the Web and Replication Servers are the same machine. If your Web and
Replication Servers are different machines, see the Configuring the
ArcFM Solution help for instructions on additional necessary steps,
including creating and configuring a domain user.

STEP 1: COMPLETE THE 1S INSTALLATION

] On the Web Server, open the Control Panel.

Building Your Mobile
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U Open Add or Remove Programs.

L From the left frame, choose Add/Remove Windows
Components.

B Ak o Memoer Prograen

Currertly e aled prosyr

B | AriFr Gedat aburie Wagd ot Toreir 9.3 L LA S o
| AP Gancsdaf abuarie Bacie afon Wb 7 e 15.004m

§ el RectDE For Miroaclt S0 Server Sow 400N
[ d03LS Ergneg Runbies Sw  BSLODME
[ Mecr el HEY Fr ettt 210 Serenc Pach 1 SEe  1ET0MB
;""J“I-\':-'.a'l HET Framesscrh 30 Serace Pack. | Sire 2SO0ME

Q) Verify that Application Server is checked, then
select it and click [ Details ].

Windows Components Wizard [ ]

Windows Components
“fou can add o remove components of Windows,

To add or remave a component, click the checkbox, A shaded box means that only
part of the component will be installed. To see what's included in a compaonent, click
Dietails.

LComponents:

Accessories and Utilities
Srver
[ [BA Certificate Services 1.8MB

O E-mail Services 1.1 MB
[7] ¢34 Fax Servires 79MR LI

Descrption:  Includes ASP.NET. Intemet Infarmation Services [[1S], and the
Application Server Console.

Total disk space required: 30MB Dt
Space available o disk 5613.4 MB &I

< Back I Hest » I Cancel | Help |

O Verify that ASP.NET is checked.

Q) Verify that 11S is checked, then select it and click
[ Details ].
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Application Server E

To add ar remave a component, click the check bax. A shaded bax means that anly part
of the component will be installed. To see what's included in a component, click Details.

Subcomponents of &pplication Server.
'ﬁ]Apphcallon Server Console 0.0 B ;I
B ASPNET 00ME
(B Enable network COM+ access 00ME
(] @ Enable network DTC access 00Me
g Intemnet nformation Services [115)

] 6= Message Queling 7OME

El

Dezcription: 115 Includes Web, FTP, SMTF, and MMTP suppart, along with suppart
far FrontPage Server Extensions and Active Server Pages [ASP]

Total disk space required: 30ME Details
Space available on disk: BE19.4 B

QO Verify that Background Intelligent Transfer
Service (BITS) Server Extensions is checked,
then select it and click [ Details ].

U Verify that BOTH boxes are checked.

Background Intelligent Transfer Service (BITS) Server Extensions

To add or remowve a component, click the check box. & shaded box means that only part
of the component will be installed. To see what's included in a component, click Details.

5

O BITS server extension ISAP]

||

Description:  Installs the BITS snap-in 2o that uzers can configure and manage BITS
b uging Microsoft Management Console.

Total disk space required: 3.2 B Details... |
Space available on dizk: 5619.4 MB
oK I Cancel |

Always check both BITS choices, not just one! ArcFM Replication
requires both BITS extensions.

U Click [ OK ] to all dialogs until you return to the
Windows Component Wizard.
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Windows Components Wizard [ ]

Windows Components
“fou can add o remove components of Windows,

To add or remave a component, click the checkbox, A shaded box means that only
part of the component will be installed. To see what's included in a compaonent, click

Details.

LComponents:

) Accessories and Utilties

i Application Server

[ [BA Certificate Services
O E-mail Services
[7] 4 Fax Semvices

Descrption:  Includes ASP.NET. Intemet Infarmation Services [[1S], and the

Application Server Console.

1.8MB
1.1 MB

7aMR LI

Total disk space required: 30MB Dt
5619.4 ME &I

Space available on disk:

< Back I Hest » I Cancel | Help |

O Click [ Next] to run Configure Components.

U When the wizard is done, click [ Finish ]

Because ArcFM GDB Replication Web is closely tied to 1S, after
changing these IS settings you may need to reinstall ArcFM GDB

Replication Web for it to function properly.

O uninstall ArcFM GDB Replication Web. Be sure
you do not uninstall ArcFM GDB Replication Server.

U Run the ArcFMGDBReplicationWeb.msi installer
available from Telvent.

 Close the Add or Remove Programs window.

U Close the Control Panel.

STEP 2: CONFIGURE THE 1S APPLICATION POoOL

Q) still on the Web Server, right-click My Computer
and choose Manage.
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An Application Pool isa
grouping of services and programs
which can be managed as a unit
(for assigning permissions, etc.).
The Application Pool ID you
specify will be visible in the I1S
Inetpub folder.

Building Your Mobile
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Open
Explore
Search...
Manage

Map Metwork Drive, ..
Disconnect Metwork Drive. ..

Create Sharteut
Delete
Rename

Properties

U Inthe Computer Management window, expand
Services and Applications = Internet
Information Services (11S) Manager.

O Computer Management =] B3

=) Fle action View Window Help ‘_ & x|
eom
=)

9 2|2 @

Mame

[ o vstem Tooks
(gl Event: Viewer g storage
% shared Folders

Bﬁsarvices and Applications
Local Users and Groups

o Ferformance Logs and Alerts
Dievice Manager
£ g Storage

& Removable Storage

& Dick Defragmenter
EY Disk Management:
Services and Applications

- 8 Telephory

Services

WM Control

[ 5L Server Configuration Manager
B Indexing Service
=8 Internet Information Services (115) Manager
[#+_) Application Pasls
) Web Sites
[+ _J Web Service Extensions

O Right-click Application Pools and choose New >
Application Pool.

U In the Add New Application Pool dialog, set the

Application pool ID (e.g.
TheApplicationPool ID).

Add New Application Pool

Application poal 10 I TheApplicationPoclID

Application pool settings

% Use default settings for new application pool

" Use existing application pool as kemplate

Application pool name: IDefauItnppF‘Dol j

oK I Cancel | Help |

U Choose Use default settings for new application
pool.
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The ArcFM GDB Replication
Service is installed by the Telvent
ArcFM Replication Web software to
receive Update Requests from Field
Units.

The application should already
exist and have the name of
“Default Application.” However,
if the application has not yet been
created, a [ Create ] button will
be visible next to the Application
Name field. After the [ Create ]
button is clicked, it will be
replaced by the [ Remove ]
button.

1S permissions will vary at every
customer site. Allow for time to
test and adjust these settings until
they are compatible with ArcFM
Replication, and ensure that an
authorized member of the customer
IT staff will be available to make
these permission changes while
you are on site. Errors stating
"Access Denied," "Can't Read" or
"Can't Write" are typically the
result of incorrect I1S permissions.

Building Your Mobile
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Q click [ OK].

U Inthe Computer Management window, under
Internet Information Services (11S) Manager
expand Web Sites > Default Web Site.

U Right-click ArcFMGDBReplicationService and
select Properties.

Ik Disk Defragmenter
Disk. Management

=- Services and Applications Explore
B Telephory Open
% SEFVICES Permissions
ugy I Control Erowse
@ S0L Server Configuration Manager ~
&8 Indexing Service [ew 4
EPJ It ion Services (115) Mana Al Tasks 4

B

Mew Window Fram Here

ﬂ!—‘ Defaul-appPool
‘}3 Default Application Delete

“ust Default dpplication Refresh

gt ThedpplicationPoolID
) Weh Sites RiEae=E
E..g Dle.FuIt wb Ste Help
-1 ArcFMGEDER eplications:

| aspret_client
) Web Service Extensions

U Choose the Virtual Directory tab.

U Ifthereis a [ Create ] button to the right of
Application Name, click this button.

U From the Application pool drop-down choose the
application pool you created (e.g.
TheApplicationPoolID).

ArcFMGDEBReplicationService Properties

HTTP Headers | Custom Errors BITS Server Extension ASP.NET I
Virtual Directory | DioCUmEnts | Directory Security
The content for this resource should come from:
& A directory locabed on this computer
€~ p share located on anather computer
€ predirection to a URL

Local path: I CiiInetpublwwrootiArcFMGDEReplica Browse... |

™ Script source access IV Log wisits
v Read |v¥ Index this resource
[ wirike:

m Directary brawsing

Application settings

Application name: I Default Application Remove |
Starting paint: <Default Web Site=\ArcF...

Configuration. .. |
Execute permissions: IScripts anly ~
Application pool: heapplicationPoolID

(s]'4 I Cancel | Apply | Help |
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Q click [ OK].

STEP 3: CONFIGURE THE VIRTUAL DIRECTORY

The Virtual Directory is simply an alias for the enterprise base path. The
Field Unit will access database updates from an address that includes the
Virtual Directory rather than the entire enterprise base path.

U Inthe Computer Management window, under
Internet Information Services (11S) Manager >
Web Sites, right-click Default Web Site.

U Choose New = Virtual Directory.

The Virtual Directory Creation Wizard will appear.

Q) In the welcome screen, click [Next ].

U For the Virtual Directory Alias, enter a name for
the Virtual Directory (e.g. TheVirtualDirectory).

¥irtual Directory Creation Wizard

Vitual Directory Alias
Specify a short name, or alias, for this vitual directory.

Type the alias you want to use to gain access to this Web vitual directory. Use the
zame naming conventions that pou would for naming a directom,

bliag:
TheitualDirectory

< Back Mext > Cancel

O Click [ Next].

U For the Path, browse to the enterprise base path
(e.g. C:\TheContainer\TheBaseFolder).
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The Virtual Directory is justa
pointer to the base directory. The
Virtual Directory name acts as an
alias, easier to enter than the
precise location of the enterprise
base directory.
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‘web Sie Content Meacbory
"wihere i e Sonberd pou wand b i on e Wl w7

Errber ths iy o e chienciionsy thal conlians B corbent for e Wit she

Pat

.

Browse For Folder

Yirtual Directory Creation Wizard

|2 Licenses
i) mssal

I Pythonzs
I2) Scripts

Make New Falder |

|2 Program Files

=l @ TheContainer
[SRE ] THeEaseFolder
I InitialExtract
I Logs
|- TheReplicaMame

o]

[F[F=h WThIDAS

O click [OK].

O Click [ Next].

U Check the Read, Write, and Browse permissions.

Yirtual Directory Creation Wizard

Virtual Directory Access Permissions
Set the access permissions for this wirtual directary.

Allaw the fallowing permissians:

[¥ Read
™ Run scripts [such as 45F)

[~ Executs [such as ISAP| applications or CGI)
IV wiite

To complete the wizard, click Next .

< Back I Mext > I

Cancel

O Click [ Next].

Q click [ Finish].

You now have a Virtual Directory listed under Web Sites. Because the
Virtual Directory is an alias for the enterprise base path, when you
expand the Virtual Directory you will see that everything contained in
the enterprise base directory is listed under the Virtual Directory.

L Expand TheVirtualDirectory to view its contents.
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E--PJ Internet Information Services (113 Manager
EI_,_J Application Pools
El-gb¥ DefaultappPool
--‘},} Default Application
- ThedpplicationPoollD
=) wWeb Sites
- Default web Site
-‘b &rcFMGDEBReplicationService
[-_J aspnet_client
E“ ThetirtualDirectory
[+ __| InitialExtract
B+ Logs
_._J TheReplicalame
[#-__J Web Service Extensions

[<]

STEP 4: ADD MIME T7YPES TO I1S

O Inthe Computer Management window, right-click
Internet Information Services (11S) Manager
and select Properties.

Intemet Information Services (115) Manager Properties K E

I nsbls Drect Matabase Lot

Al
nEnng

UTF-0 Logang
Abowry local
cadde page.

I Ereinde Webs ke 1 TP

MIME types
5 ooy iy s wath extarmscns
ey oqptreed b MIVE Lypes b To 2 T,
miessl configure addtonal Fle extensions,

chek MEME Tymes.

U Inthe Internet Information Services (11S)
Manager Properties, click [ MIME Types ].

O Inthe MIME Types window, click [ New ].
U For Extensions enter .delta

O For MIME type enter
application/octet-stream

MIME Type
Extension: I Jdelka
MIME type: I application/octet-stream
’TI Cancel
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Q click [OK].
O Inthe MIME Types window, click [ New ].
U For Extensions enter .xip

O For MIME type enter
application/octet-stream

U Click [ OK ] to all dialogs.

MIME Types

Registered MIME types (file extensions):

MIME type: application/octet-stream

oK Cancel

O Right-click TheVirtualDirectory and choose
Properties.

U Choose the HTTP Headers tab.
O Click [ MIME Types ].

U If the .delta and .xip types are not listed here, add
them.

U click [ OK] to all dialogs.

U Close the Computer Management window.

STEP 5. SET WEB SERVER PROPERTIES IN THE ARCFM
GEODATABASE REPLICATION ADMINISTRATOR

Q) still on the Web Server, from the Start menu, choose
Programs > ArcFM Solution > ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Administrator.
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1 In the ArcFM Geodatabase Replication Administrator,
from the File menu choose
Open Configuration File.

nArEFM Geodatabase Replication Administrator
Filz Action Help

Mew Configuration File  Ctrl+r

onfiguration File  Cerl+Shift-+0
Save Configuration Fle  Chrl+5
Save Al hrl+Shift+5

B [Name]
MNarne ArcFM Geodatabas

Exit

O Browse to
C:\Inetpub\wwwroot\ArcFMGDBReplicationSer
vice\Web.config.

QO click [ Open].

Q) If the Web.config file includes any sample replicas,
such as NortheastElectric or

If your Backdrop geodatabase NortheastLandbase, right-click each one and choose
were a file geodatabase, you would Remove

choose New > File

Geodatabase Replica instead. . . . . .
Tracking Web Server use is optional, but for this class you will keep

tracking turned on.

U Select the Web Service node.

U Set Log Client Activity to True.

HArCFM Geodatabase Replication Administrator*
File Action Help
D= EHd
E|---f-‘-_': ArcFM Geodatabase Replication E General
EII:I C:AInetpubtwwwrootsbicFMGOBRE | Fame web Service
E--t;] “Web Service Log Clignt Activity True d
L] General
Log Client Activity
Thiz value specifies whether or not client connections and downloads are logged.
«| | »

Next you will specify implementation details for your replica.

U Right-click the General category and choose New >

Personal Geodatabase Replica Web Service.
If your Backdrop geodatabase

were a file geodatabase, you would . .
choose New > File U For Replica Name, enter the same Replica Name

Geodatabase Rep“ca instead. Used in the Rep|icationCOI’lsole.exe.Config f||e
configured earlier (e.g. TheReplicaName).
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The Replica Name must be
identical on the Replication Server,
Web Server, and Field Unit for

replication to succeed.

A Base UNC value is only
necessary if you use UncCopy
instead of BITS.

All slash (virgule) characters in
the Base URL must be forward
slashes, not back slashes.
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a ArcFM Geodatabase Replication Administrator®
File Action Help

O EHd

E|--7=-'-'J ArcFM Geodatabase Replication E{

E General
Replica Mame TheReplicaM ame
Perzonal Geodatabaze File Mame

E||:| C:AInetpubhwaroot’arcFMGDER
=€ web Service

The Replica Name must be entered into the server
ReplicationConsole.exe.config, Web.config and the client
ReplicationConsole.exe.config with exactly the same spelling. If the
Replica Name differs in any of these three locations, replication will fail.

U For Personal Geodatabase File Name, browse to
the Backdrop geodatabase in the Enterprise Server
base path (e.g. C:\TheContainer\TheBaseFolder\
InitialExtract\Backdrop.mdb).

QO click [ Open].

U For Base Directory, browse to the Enterprise Server
base path (e.g. C:\TheContainer\TheBaseFolder).

QO cClick [OK].

(] For Base URL enter the server name and Virtual

Directory name (e.g.
http://vm-mobileed/

w ArcFM Geodatabase Replication Administrator M= E3
Fle Action Help
e
E-87] ArcFM Gendatahase Repliation B General
1771 CMnetpubhwmmnootscFMGDBRS|  Fieplica Name TheReplicaName
=43 Web Service Personal Geodatabase File Name Backdrop.mdb
2 Genersl Base Directory C:ATheContainer\TheBaseFolder
{8y TheReplicallame Base UNC
hitp:/#vm-mobileed/TheVirtualDirectory
Base URL
Specify the hitp path [ttp: //Computerame/AitualBaseDir] to your vitual diectory. This path is
| | tequired by clients using the BITS transport method.
4 »
Configuration Erroes
Name | Propery | Dieseription | Path |
Ready 4
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L (Optional) To log each time a field unit retrieves an
update, select the Web Service node and set Log
Client Activity to True.

U From the File menu, choose Save All.

QO I1f any Configuration Errors appear at the bottom
of the window, resolve them.

L] Once all errors are resolved, save the settings and
close the ArcFM Geodatabase Replication
Administrator.

STEP 6. TEST THE WEB SERVER CONFIGURATION

The only part of the second URL
that will change from one customer
to another is the name of the Web

Server. The
ARCFMGDBREPLICATION
SERVICE web site is created when
the ArcFM GDB Replication Web
software is installed, and always
has the same name.
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When the Web Server is correctly configured, the Field Unit can view
the contents of the Enterprise Server base directory (using the Virtual
Directory) and access the Web Server’s replication services.

L On the Field Unit, open the Internet Explorer web
browser.

L In the Address bar, enter the Base URL - the same URL
you set in the ArcFM Geodatabase

ReplicationAdministrator (e.qg.
http://vm-mobileed/

TheVirtualDirectory).
ﬂ vm-mobileed - /TheVirtualDirectory/ - Windows Internet Explorer @@@
@. 4 v & hitp:ffm-mobileed/ThevirtualDirectory/ o 5[ X i

Fle Edt Wew Favorites Tools Hslp

- »
U | @ yme-mobieed - [ThevirtualDirectory/ 3 - =~ i page v () Tools -

vm-mobileed - /TheVirtualDirectory/

[To Parent Directory]
Tuesday, September 18, 2008 5:23 PM <dir> InitialExtract
Tuesday, September 18, 2008 4:40 PM <dir> Logs

Tuesday, September 16, 2008 5:38 PM <dir> TheReplicallame

Done S Local intranet F100% <

L Once that web page loads successfully, test the URL
http://vm-mobileed/
ArcFMGDBReplicationService/

gdbreplicationwebservice.asmx (use the
customer Web Server name in place of vim-mobileed).
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= GDBRe plicationWebService Web Service - Windows Internet Explorer
Q ;¥ | €] http:/fvm-mobileed ArcFMGDEReplicationService ¥ | | ¥4 X -
Elle Edit Wew Favortes Tools Help

B " 2
F 4 | @8 GDEReplicationWebService Web Service G- 8 o T op Page v (0F Tools -

| GDBReplicationWebService

The following operations are supported. For a formal definition, please review the Service Description.

If the Rep|lcati0n and Web Servers b S;L[Lilel:;iflfﬁrences for a replica based on an identifier
are separate (a distributed T T
. . A . repares a full download for a replica
implementation), you will still use i ! )

q * ValidateReplicaNameExists
the Web Server’s name in both of validates that a replica name exists on the web.
these URLs.

< b4

Done ‘JJ Local intranet #100% T

L I either page does not load successfully, resolve the
problem before proceeding.

PART 4. CONFIGURING CLIENT-SIDE REPLICATION

STEP 1: CREATE THE FIELD UNIT BASE PATH

L] On the Field Unit, create a new folder and subfolder at

The Field Unit base path does not the top level Of_a drive (e.g.
have to be identical to the C:\TheContainer\TheBaseFolder).
Enterprise Server base path.

STEP 2: SET FIELD UNIT PROPERTIES IN THE ARCFM
GEODATABASE REPLICATION ADMINISTRATOR

U still on the Field Unit, from the Start menu, choose
Programs > ArcFM Solution > ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Administrator.

L) From the File menu choose
Open Configuration File.

U Browse to Program Files\Miner and Miner\ArcFM
Solution\Bin\ReplicationConsole.exe.config.

QO click [ Open].

tlp Alternately, you could right-click U Select ReplicationConsole.exe.config in the tree.
ReplicationConsole.exe.config in the

tree to choose New > Client.
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The Replica Name must be
identical on the Replication Server,
Web Server, and Field Unit for
replication to succeed.

Microsoft BITS technology
downloads files in the background
while the end user does not need
the bandwidth for other tasks.
BITS can also resume an
interrupted download instead of
starting again from the beginning,
unlike UncCopy.
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] From the Action menu choose New > Client.

5 ArcFM Geodatabase Replication Administrator,
File | Action Help

?‘lj [ MNew » Client
= Server
5 __,EI._._..._. T B General

U For Client Base Directory browse to the Field Unit
base directory (e.qg.
C:\TheContainer\TheBaseFolder).

O click [OK].

U Right-click General Category and choose New >
Personal (or File) Geodatabase Replica Client.

&) ArcFM Geodatabase Replication Administrator*
File Action Help

O Hd
= i"-": LicFM Geodatabase Replication E Category Mame
=1 D:\Program FilestMiner and Miner\& | Categary Mame General Category
=8 Client

Gieneral Categq

Directory Replica Client
Rename File Geodatabase Replica Client
Remave Personal Geodatabase Replica Client
Validate Chrl+Shift+4 Process Framework Replica Client

Mews Configuration File  Cerl+M
Save Configuration File Chrl+5

U For Replica Name type TheReplicaName

The Replica Name must be entered into the server
ReplicationConsole.exe.config, Web.config and the client
ReplicationConsole.exe.config with exactly the same spelling. If the
Replica Name differs in any of these three locations, replication will fail.

O Verify that Enabled is set to True.

U For Personal (File) Geodatabase File Name, type
Backdrop.mdb or Backdrop

U For Transport method choose Bits.
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B ArcFM Geodatabase Replication Administrator
File Action Help

De  dd
= :} ArcFid Geodatabase Replication Replica Mame TheReplicaM ame j
=7 D:MProgram Files\Miner and Miner® | Enabled True
-8 Clent Perzonal Geodatabase File Mame Backdrop.mdb
=3 E‘enera\ Categary Transport Method Bits

U Do not change the default values for any
Replica Update Settings.

All slash (virgule) characters in .

the Web Service URL must be a Eor th_e/}Neb S%ry;ce chJ/RL enter

forward slashes, not back slashes. ttp://vm-mo - ! e? _
ArcFMGDBReplicationService/

GDBReplicationwebservice.asmx (use the
customer Web Server name in place of vm-mobileed).

B ArcFM Geodatabase Replication Administrator E@E‘

File Action Help

D Ed
= 2] brcFM Geodatabase Replication Replica Name TheReplicaName El
=-[] D:\Program Files‘Miner and Minerd | Enabled True
= ﬂz} Client Personal Geodatabase File Mame Backdrop.mdb
=1-_1 General Category Transport Method Bits
TheReplicaM ame B ReplicaUpdate Setiings
Update Interval [Days. HH:MM:55) 00:00:00
Mumber OFf Retries 5
Murber Of Retries For Full Downloads 3
Fietry Interval [Daps HH:MM:55) 00:15:00
E ReplicaWeb Service Seliings

ice URL http:4F bileed/arch plicati vice
e Timeout [minutes) 00:05:00 =

L) From the File menu, choose Save All.

U I1fany Configuration Errors appear at the bottom
of the window, resolve them.

L] Once all errors are resolved, save the settings and
close the ArcFM Geodatabase Replication
Administrator.

STEP 3: TEST THE FIELD UNIT CONFIGURATION

L still on the Field Unit, from the Start menu choose
Programs > ArcFM Solution = ArcFM
Geodatabase Replication > ArcFM Geodatabase
Replication Client.
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B ArcPm Replication Status E|§|E

TheRephcal ame
Fieplication Complete
Statuz changed at: 10/14/2008 11:43 Ak

Lazt Update: 10/14/2008 11:43:41 AM

==

Q) If any errors appear, look in the Event Viewer for more
information. Any message requesting you retry
replication indicates an error. After making
corrections, you must exit and restart the Replication
client process (not just choose Update Now) for your
changes to take effect.

L When replication succeeds without producing any
errors, observe that a Replica Name folder has been
created on the Field Unit (e.g.
C:\TheContainer\TheBaseFolder\
TheReplicaName). Inside this folder will be the
Backdrop database. Do not open this file!

PART 5: CONFIGURING THE LOGIN DATABASE

If implementing Redliner or Inspector, to allow field users to save
redlines (graphics and ink) in a Session/Design without requiring an
ESRI ArcEditor license, the Stored Display showing when a new
Session/Design is opened must include a layer from a feature class which
meets all three of the following criteria:

e |snotin a network
e AND is in a dataset that does not contain a network
e AND does not have feature-linked annotation.

Otherwise, to allow field users to store redlines in an ArcFM Annotation
Feature Class, this class must be included in the backdrop geodatabase in
a dataset of its own.

STEP 1. PREPARE THE DATABASE FOR USE

Telvent provides a sample Login database that you can tailor to fit a
client’s Mobile implementation. You will start by uncompressing the
sample Login database, then update it to ensure that it is compatible with
the current version of ArcFM.

O Double-click the sample
MinervilleMobileLogin_version.exe to unzip it.
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By default, the self-extracting
MinervilleMobileLogin_version.exe
places the extracted
MinervilleMobileArcFMLogin.mdb
in C:\Program Files\

Miner and Miner\ArcFM
Solution\Sample Data\
MobileSolution.

You may name the Login database
anything allowed by your
operating system. The Login
database name will be visible to
field users.

If your Stored Displays will be
altered on an ongoing basis,
consider creating folders on the
Enterprise Server and the Field
Units for directory replication.
Directory replication can
propagate updated copies of the
Login database to all Field Units.

Building Your Mobile
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Q click [ Unzip].

L When the extraction is complete, start ArcCatalog.

WinZip Self-Extractor - MinervilleMobileLogin_9... [X]

To unzip all filez in this self-extractar file to the
zpecified folder prezz the Unzip button,

Run Winsip

Unzip to folder:

iortSample D atabMobileS olutiorn Browse... |

i

Unzip

LCloze

¥ Ovenarite files without prompting

i

About

Help

O Using ArcCatalog, copy and

paste the

MinervilleMobileArcFMLogin.mdb database into
the Enterprise Server base directory (e.g.
Z:\TheBaseFolder).

=3 ArcCatalog - Arclnfo - Z:\

Elle Edit ¥iew Go Tools Window Help

D5

Location ‘Z N

[ catalog A 5
(G c\ ame

= a Z:\ (] TheBaseFolder

=-{_1 TheBaseFolder
+-{11 InitialExtract
+-_] Logs
+- (L] TheReplicaName
+- 3 Login

(%) Database Connections v | %

x CnntanllerE,ﬂE4 »

L Rename this new copy of

MinervilleMobileArcFMLogin.mdb if desired. In
these steps, the database will be called Login.mdb

U Right-click Login.mdb and choose Create/Update
ArcFM Solution System Tables.

U Right-click Login.mdb and choose

Upgrade ArcFM Solution

Database.
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STEP 2: CHANGE THE DATA SOURCE FOR STORED DISPLAYS

To delete a table, right-click over it U From the Login.mdb database, delete the following
and choose Delete. tables:

MM_STORED_DISPLAYS
MM_SYSTEM_STORED_DISPLAYS
MM_PACKAGES
MM_SYSTEM_PACKAGES

3 ArcCatalog - Arclnfo - Z:\TheBaseFolder\Login.mdb\MM_S.... [= |[B][X]

File Edit View Go Tools Window Help

o x QO N2

Location: |Z:"-.The BaseFolder\Login mdb\MM_SYSTEM_STORED_DISPLAYS

%|| Contents lF‘revie i
MM_PERSIST_INFO ~
MM_SNAPPING Name:  MM_SY™
MM_STORED_DISPLAYS Type:  Person
MM_SYSTEM_DOCLIMENTS
MM_SYSTEM_PACKAGES
MM_SYSTEM_PAGE_TEMPLATES
MM_SYSTEM_PERSIST_INFO

v
If using SQL Server, connect to the MMENG_ANCHORCAPACITY o JIES >
database that contains the MM

tables (usually “sde”), not the
database that contains the feature

classes (usually “arcfm”).
U 1f including Page Templates in the Login database,

delete the tables MM_PAGE_TEMPLATES and
MM_SYSTEM_PAGE_TEMPLATES.

U Connect to the enterprise SDE geodatabase using the
sde database and sde.DEFAULT version, as user
sde.

L From the enterprise SDE geodatabase, copy the
following tables:

MM_STORED_DISPLAYS
MM_SYSTEM_STORED_DISPLAYS
MM_PACKAGES

MM_SYSTEM _PACKAGES

U Paste these tables into the Login database.

O If including Page Templates in the Login database,
copy the tables MM_PAGE_TEMPLATES and
MM_SYSTEM_PAGE_TEMPLATES from the
enterprise SDE geodatabase to the Login database.
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Next you will create a testing copy of the base path for use in setting the
correct data source for all the layers of the Login database Stored
Displays. The testing base path must have the same path as the Field Unit
base path.

L] On the Enterprise Client, create a folder and subfolder
with identical names and drive locations as the
Enterprise Server Base Path (e.g. C:\ TheContainer
\TheBaseFolder).

U Create a folder named for the Replica Name (e.g.
TheRepl icaName) inside the testing base path
(C:\TheContainer\TheBaseFolder).

U Using ArcCatalog, copy the Backdrop geodatabase
from the Enterprise Server base path
(Z:\TheBaseFolder) to the Enterprise Client testing
base path (C:\TheContainer\
TheBaseFolder\TheReplicaName).

U Right-click Login.mdb and choose ArcFM Data
Source Wizard.

O Click [ Next].
L Check the box for Stored Displays. If including

Page Templates, also check the box for Page
Templates.

i r
i ArcEM Data Source Wizard

Select Stored Items

Select the ikems that should have their data sourc

+ Stored Displays
+- [J Documents
+-[]Page Templates
+- [JMap Baoks

O Click [ Next].
U Choose Set all data sources.
QO Click [ Next].

U Choose Personal or File Geodatabase.

Building Your Mobile Mobile Checklist B: Configure Replication - 40
Copyright © Telvent



Do NOT browse to the Backdrop U cClick [ Choose data source... ].
geodatabase on the Enterprise Server

or Field Unit! If you do so, the data

source path will contain theEnterprise U Browse to the Backdrop geodatabase in the
Server or Field Unit machine name Enterprise Client testing base path (e.g.
(e.g. Ywm-mobileed\TheContainer C:\TheContainer\TheBaseFolder\

\TheBaseFolder\InitialExtract) instead
of the local base path (e.g.
C:\TheContainer\TheBaseFolder\
InitialExtract). If the machine name is 4 click [ OK].
hardcoded, the Login database will

only be usable on that one machine,

TheReplicaName\Backdrop).

= - - F =
instead of all Field Units. B ArcFM Data Source Wizard g‘
Set the Destination Data Source
Select the data source to which the layers will be connected when the update is
complete.

" ArcSDE Database

Server:

|
Service: |
|

Authentication: | J

{* Personal or File Geodatabase

Path: |C.\TheCurrtainsr\ThsBaseFuIdEr\Ths ReplicaMame'\Backdrop.mdb

Choose data source. .

O Click [ Next].

Q Verify that the path begins with the drive name (e.g.
“C:\” ) not any machine name (e.g. “\\vm-
mobileed”).

B ArcFM Data Source Wizard E\

Summary
A summary of the updates that will be made. %

“You have chosen to changethe connection information for 12 stored displays, 0 documents, 0 page
templates and 0 map books.

All the layers will be set to the destination data source.

path: C:\TheContaineriTheBaseFolderiTheReplicaName'\Backdrop. mdb

O Click [ Next] again.

QO If prompted to connect to the enterprise SDE
geodatabase, connect to the sde geodatabase as
user sde using the sde.DEFAULT version.

L When the wizard is finished, click [ OK ].
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Implementation-Specific Steps

Applies to: Implementations allowing users to place graphics
Basic Redliner, Advanced Redliner, Inspector,
Mobile ArcFM, Mobile Designer

O Right-click entSDEgdb and choose ArcFM Favorites.
U Export the Graphic Favorites.
0 Right-click Login.mdb and choose ArcFM Favorites.

O Import the Graphic Favorites.

Implementation-Specific Steps

Applies to: Implementations allowing spatial edits
Mobile ArcFM, Mobile Designer

Right-click entSDEgdb and choose ArcFM Favorites.
Export the ArcFM Favorites and/or CUs.

Right-click Login.mdb and choose ArcFM Favorites.

(I R I W

Import the ArcFM Favorites and/or CUs.

L On the Enterprise Client, start ArcMap.

O Inthe Login to ArcFM screen, log in to the Login
database in the Enterprise Server base path. The user
name does not matter.

L On the ArcFM toolbar, from the Stored Items menu,
choose Stored Items Manager.
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Stored Displays with fewer layers
generally have better performance.

Building Your Mobile
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Stored Items Manager

Page Templates Stored Displays } Documents |
=|-{F System Stored Displays
@ Electric Only ﬂ ﬂ
& Gas only
R
4oy e
{1 User Stored Displays (arcfm) T
Close

L Remove any Stored Displays that field users will not
need.

O Click [ Close].

L For each of the Stored Displays that the field users will
need:

0 Make sure the Stored Display contains only the layers
field users will need. Remember to remove any
unnecessary non-spatial tables on the Table of
Contents > Source tab.

o0 Make sure all of the layers point to tables included in the
Backdrop database in the testing base path.

o From the Stored ltems menu choose Save to save
your changes to the Stored Display.

O If including Page Templates in the Login database, on
the ArcFM toolbar from the Stored Items menu,
choose Stored Items Manager.

0 On the Page Templates tab, delete any unneeded
Page Templates

o0 Test each remaining Page Template. Page Templates
which use external files (e.g. logo image files) may
display a broken link. Correct this by deleting the link,
then copying and pasting the image into the Page
Template instead of using Insert menu > Picture or
Insert menu > Object.
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Implementation-Specific Steps

Applies to: Implementations allowing users to place graphics
Basic Redliner, Advanced Redliner, Inspector,
Mobile ArcFM, Mobile Designer

U Display the Graphics tab (Tools menu > Options >
TOC tab).

U Confirm that the graphics you imported are present.

Implementation-Specific Steps

Applies to: Implementations allowing spatial edits
Mobile ArcFM, Mobile Designer

U Start Editing.

U Verify that the Feature Favorites and/or CU
Favorites you imported are present.

U Stop Editing.

U Close ArcMap.

Next you will share the Field Unit base directory in order to copy the
Login database from the Enterprise Server to the Field Unit.

L On the Field Unit, right-click the top base path folder
folder (e.g. C:\TheContainer) and choose Sharing
and Security.

U Check Share this folder on the network.

U Check Allow network users to change my files.

O click [OK].

L On the Enterprise Client, map a drive to the Field Unit
folder (e.g. C:\TheContainer).

(1 On the Enterprise Client, using ArcCatalog, copy the
Login database from the Enterprise Server base path
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to the Field Unit base path (e.g.
C:\TheContainer\TheBaseFolder).

STEP 3 TEST THE LOGIN DATABASE

A field user views geodatabase data by connecting to the Login database
and applying a Stored Display. The Stored Display retrieves data from
the Backdrop geodatabase for display to the user. In this step you will
use the ArcFM Engine Administrator to create and test the Login
connection, then test each Stored Display.

Implementation-Specific Steps

Applies to: Implementations on the ArcMap platform
Mobile ArcFM, Mobile Designer

U On the Field Unit, start ArcMap.

O In the ArcFM or Designer login screen, browse to the Login
database.

L Test that all layers of all Stored Displays appear
correctly.

(L Test that all Page Templates appear correctly.

L Do NOT start editing. Never edit the Backdrop database
directly.

 Skip all instructions below regarding the ArcFM Engine
Administrator and ArcFM Viewer for ArcGIS Engine
and jump to the next step.

(] On the Field Unit, run Start > Programs > ArcFM
Solution > ArcFM Engine Administrator.

O Choose the Login tab.

QU Right-click Login Connections and choose
Add Connection.
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- -

ArcFM Engine Administrator

—, / - h
Login % Lapout and Licenses

Login Connection

Add Connection

Mame:

Geodatabaze:

L On the right side of the window, for Name type a
connection name for future use by end users (e.g.
CourseLoginConnection).

=

2 ArcFM Engine Administrator

Login % Lapout and Licenses \-\

= Login Connections
Marquette_ORACLE

CourseLoginConnection |

Elmo_DIRECTCOMMECT Name:
If ArcGIS Desktop is installed on the pinenlend Geadatahase:
. . . celot_SOLServer Path
Field Unit, you will see the Select CourseLoginCarmection

New Database Connection
dialog instead of the
Geodatabase Properties
dialog. Regardless of which dialog
you use to specify the Login
database, the resulting connection

will be the same. U Under Geodatabase, click [ Browse ].

U From the DBMS Provider drop-down choose MS

Selecl New Dalabase Conneclion

Lockin: |0 TheRaseFolder v| 2 ++| 1|38 Access
[ rasre Tyoe
I Therepkcabisme Folder

U Inthe Path field enter the path to the Login

database on this Field Unit (e.g.
C:\TheContainer\TheBaseFolder\

—e - Login.mdb).
Geodatabase Properties le
DBMS Provider: | MS Access v
Server: | |
Service: | |
Path: |C:\TheC.ontalnar\TheEasaFoIder\Logln.mdb |
Version: | |
Authentication
QO cClick [OK].
Do NOT connect to the Backdrop database using this tool. Instead, the
Stored Displays in the Login database will point to the Backdrop
database.
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«‘S’s ArcFM Engine Administrator

/ Login Y Layout and Licenses ',
= Login Connections
Marquette_ORACLE -
Emo_DIRECTCONNECT Name: CourseLoginConnection
Minerville mdb Femar i
el Path: C:\TheContainer\ TheBaseFolder\Login mdb
Course LoginConnection
Process Framework:
Connection String
[ o J(cme J[ &b |
Ready

Do NOT enter any information in the Process Framework (PX) area.
You will create and configure the field Process Framework database in a
later exercise.

O Inthe ArcFMm Engine Administrator window, click
[ Apply ] .

U Show the Layout and Licenses tab.

(]

In the tree on the left, select Licenses.

L In the licenses list on the right, verify that only the
licenses which will be available to this machine are
checked, and that all licenses necessary to run the
software are checked.

O click [OK].
Q) still on the Field Unit, run Start > Programs >
ArcFM Solution > ArcFM Viewer for ArcGIS

Engine.

O Log in using the newly-created connection to the Login
database. The user name does not matter.
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ArcFM Viewer for ArcGIS Engine

™

ArcF
SOLUTION

é 5

CourseLognConnection

Ctabse
Tl ot e, Thn s ok L ek

U From the Stored Display menu, apply each Stored
Display and look for any broken layers (identified with
a red exclamation mark).

% Data View - ArcFM Viewer for ArcGE Fngine

Bie fiow Selection | Stored Doplrs | Took  Wirdoss Helo

B Tabin ol Conteris Dasgner Dactric Oly B DotnView ', L3

Dlectric and Land
Dhestric fgpend
Dhestric rly

QO If you included Page Templates in the Login
database, test each one by choosing File > Print.

If there are any problems with any Stored Displays and/or Page
Templates, correct them by opening ArcMap on the Enterprise Client
and making the necessary changes to the Enterprise Server Login
) database Stored Displays and/or Page Templates. Close ArcMap, use
@ M0 Ve E21fe e SEHES| IR, e e ArcCatalog to re-copy the Login database from the Enterprise Server to

View menu choose ArcFM Locator. . . .
From the Locator Tool drop-down, the Field Unit, and re-test the altered Stored Displays and/or Page

choose Attribute Query. From the Templates.

Search drop-down, choose the desired

feature class. Enter the feature’s Once your Stored Displays display correctly, you may also locate the

enterprise SDE geodatabase ObjectiD  faatyres you edited in the enterprise SDE geodatabase to verify that the

into the ServerOID field, then click . . - .

Find. edits you made have been applied to the Field Unit Backdrop
geodatabase.

PART 6. ADDITIONAL TASKS

U For all implementations using ArcFM Viewer, use the
ArcFM Engine Administrator to configure ArcFM Viewer
interface settings (toolbars, dockable windows, etc.).

0 Configure Directory Replication (ideally for the Login
database) if desired.

CHECKLIST END
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